Support » Plugin: Wordfence Security - Firewall & Malware Scan » WF 6.2.3 XAMPP Connection Reset

  • Resolved kkkwj

    (@kkkwj)


    This is the third time this problem has happened to me, but this time I tracked it to Wordfence. So I am hopeful of a solution, eventually.

    I develop locally on XAMPP. Normally everything runs fine, sometimes weeks a time. Then one morning I’ll come in and be totally locked out of my local site with the familiar “Connected Reset” error message. Previously I would reinstall WP, reload from a backup, and manually replace my work since the last backup.

    This time I managed to find references to WF on the net, and am VERY happy to report that renaming the wordfence directory allowed me to log in as normal. I like Wordfence. I love getting those email reports once in a while about what’s happening on my demo server up in the cloud.

    For this problem:

    – It occurs to me that I lost my home internet connection for a few minutes yesterday morning. That’s the only unusual thing that I can think of that might have triggered the problem. But the site worked fine for the rest of the day. Maybe something happened overnight? Maybe WF does a daily action when the timestamp passes midnight, and picked up the lost internet connection glitch? Just struggling for ideas here…

    – I loaded wordfence assistant, disabled wordfence firewall as instructed, renamed the wordfence dir back to normal, and got Connection Reset lockout immediately. So the assistant is not working in my case. So probably I’ll have to delete the whole WF plugin and start the security config process over again.

    But before I do that, can anything be done with my current WF directory to find out what settings actually blocked me out? What security settings I should beware of when I reconfigure it? Or maybe a fix for the assistant so that it lets me rename my wordfence directory to normal, to see what’s going on? Thank you

    • This topic was modified 5 years, 9 months ago by kkkwj. Reason: added more info
Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter kkkwj

    (@kkkwj)

    An update, I managed to get the assistant working, so now I’m up and running again, with the Wordfence plugin loaded but disabled. Now I’ll activate it to see what I can see.. Thank you for that WP Assistant!

    Updates:

    – As soon as I activate Wordfence, I get the Connection Reset error and can’t see anything in my site. It would be really nice if the Assistant had the ability to inspect the WF settings, or dump the log or something.

    – I told the assistant to disable the firewall, delete tables, locked ips, and live traffic data. (I pressed all 4 buttons in the assistant, multiple times).

    But as long as the wordfence folder is there, I get the connection reset lockout error. I even deleted and reinstalled the WF plugin, but as soon as the NEW installation created the folder, the Connection Reset error showed up again.

    It’s almost as if someone is watching for that folder, and locking out the whole site as a response to a spam folder or something (just playing with ideas here). I also run the WP Security plugin. It’s a puzzle.

    For now, Wordfence has to stay uninstalled, so I can get some work done…

    • This reply was modified 5 years, 9 months ago by kkkwj.

    Hi kkkwj,
    Are you using XAMPP on Windows?
    Although it’s not recommended to use Wordfence on Windows (please check the plugin operating system requirements), but I think you may find this workaround helpful.

    Thanks.

    Thread Starter kkkwj

    (@kkkwj)

    Ah… Thank you for your post! It is most interesting that the system requirements explicitly disavow Windows use, and Windows support. I am indeed using XAMPP, so I am clearly offside of the doc. I found out about Wordfence from a course on how to develop locally on Windows, so I never checked the system requirements myself. I also download my web hosting site (unix, with Wordfence) to my Windows and iMac machines for local development.

    So maybe the solution is to leave Wordfence installed, but turn it off immediately when I get on Windows.

    As for the workaround (thank you for that reference)–I came across that, and tried it, but it did not help me at all. In fact it caused Apache to abort, because the XAMPP default Apache httpd.conf doesn’t load the winnt module.

    By the time I flogged through hours and hours of googling and trying fixes and experiments, I eventually gave up and posted here. And… according to the doc, giving up was the right thing to do–I never should have tried it initially!

    So all is well now. Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WF 6.2.3 XAMPP Connection Reset’ is closed to new replies.