Support » Networking WordPress » Went Multisite, then changed my mind, now I can't get the wp-login to show

  • Resolved ELowe


    I made a big mistake today and tried to create a multisite set up for my website. When prompted, I moved all the files to the root (they had been in a sub-directory). Once I had established that, the appearance of the site was not to my liking, so I impulsively moved everything back.

    My problem is this:

    1. All my files are in place
    2. I corrected the .htaccess & wp-config files
    3. The database seems to be okay (I deleted all the pieces that the multi-site exercise created)
    4. When I point my browser to my usual log in screen, the php code returns a blank page. So I can’t get into the dashboard to correct permalinks, etc.

    Additionally, when I point to the sub-directory, I get a listing of all the php files

    Any ideas?

    I’m running 3.1

    Site should be here
    Files located in subdirectory “wp”

Viewing 15 replies - 1 through 15 (of 23 total)
  • Oh, this is what my .htaccess file looks like:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    Could this be as simple as adding ‘wp’ to the RewriteBase line in the .htaccess file?

    Hi Elowe!
    The installation of WordPress Multisite always suggest to backup wp-config.php and .htaccess before converting into Multisite. If you have backed up then restore it. If not then following are the lines of default .htaccess file of a WordPress blog.

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME}!-f
    RewriteCond %{REQUEST_FILENAME}!-d
    RewriteRule ./index.php [L]
    #END WordPress

    Take a look at for more information. Steps:
    1. Backup Current file to a safe location.
    2. Copy it and remove its content as shown above or in the Website referred.
    3. Upload to the root folder.
    4. Right click the file in FTP and set the permissions to 644.
    5. Open Your Website and a post
    6. Come back and set the permissions to 666.

    Please inform whether it works or not.

    Thanks Krsna.Booti

    I tried restoring my saved version of .htaccess & wp-config, to no avail.

    If were to delete my database & wp files, do a clean install, then import my saved database, would that solve this problem?

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Go to

    Your index.php is missing. NOTHING WordPress will work without that 😀 Grab a fresh copy from

    I know that. I put up an html page as a placeholder for now until I sort this out. It wasn’t working with the index.php either. I will try again and check back.

    Hi ELowe!

    The problem can be solved with clean installation of wordpress but this will take a lot of time. Please try below steps before the same.

    I hope you have removed amendments to get WordPress into multisite already. However, I request you to check again whether you have removed following things properly or not.
    1. Remove all the lines added to wp-config.php
    define( ‘MULTISITE’, true );
    define( ‘SUBDOMAIN_INSTALL’, false );
    $base = ‘/’;
    define( ‘DOMAIN_CURRENT_SITE’, ‘localhost’ );
    define( ‘PATH_CURRENT_SITE’, ‘/’ );
    define( ‘SITE_ID_CURRENT_SITE’, 1 );
    define( ‘BLOG_ID_CURRENT_SITE’, 1 );
    2. Change the ‘true’ option of following line to ‘false’
    define(‘WP_ALLOW_MULTISITE’, true);
    3. Remove the two fields added to the users table that are multisite-only (deleted and spam columns).
    4. Remove the following tables in database (prefixed by your DB prefix which is generally wp_):
    1 wp_blogs
    2 wp_blog_versions
    3 wp_registration_log
    4 wp_site
    5 wp_sitemeta
    6 wp_signups
    7 wp_sitecategories (if you have global terms enabled)

    If yes, then
    1. download the wordpress 3.1 setup zip file.
    2. Extract it and edit wp-config-sample.php in the same way to install a fresh wordpress website.
    3. delete the .htaccess file.
    4. Try to login in wordpress dashboard.
    5. Go to Settings>Permalinks and regenerate the .htaccess file.

    If still it does not work then you can go for clean installation of WordPress. I hope you know how to retrieve your posts from the earlier database.

    In the past, I’ve had the index.php in the root, with everything else in my subfolder (wp). When I put the index.php in the subfolder, all I see when I point to my domain is a listing of the root.

    Naturally, I don’t want that! I put the index.php back in the root and returned to my original problem.

    Next, I added another copy of index.php to the subfolder, and now get an error message.

    From that page I can see that the permalinks have added a “blog” subfolder, which doesn’t exist.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    It won’t work without it. Ever.

    With it, I get a page with errors. Which is progress! 😀

    Viewing the source, I see" and that tells me you’re doing the old ‘put WP in a folder, have it act like it’s in root!’ trick. Except… For some reason when I go to it redirects me to

    THAT isn’t right. It should be which comes up unstyled.

    Can you share the content of your .htaccess? I think you have some goofiness going on between that and POSSIBLY your wp-config.php

    You may need to force this in your wp-config.php for a bit:

    define('WP_SITEURL', '');
    define('WP_HOME', '');

    Thanks for the detailed instructions Krsna.Booti, I’ll go through that checklist and report back.

    Ipstenu: my .htaccess lines read like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Of note –

    You CAN have the index.php in root, but there are TWO requirements, and I’m betting you didn’t follow them right now.

    1) You COPY the file from /wp to /
    2) You EDIT the copied file

    Steps 8 and 9 from the link:
    8. Open your root directory’s index.php file in a text editor
    9. Change the following and save the file. Change the line that says:
    to the following, using your directory name for the WordPress core files:

    Do that INSTEAD of what I said with the defines, see if it helps.

    The .htaccess looks good, so this is the likely culprit.

    That’s getting me closer I think. Still not getting the right theme, but I’m not too worried about that. Of more concern is the lack of proper links, and the fact that I can get to a log in screen (without the wordpress theme) but when I try to log in, I get a page not found error.

    Krsna.Booti – I had deleted all the items listed in your last post. I’m checking to see if the two fields in the users table are still there right now.

    I think there must be something left over from the multi-site exercise, because the links that show up on the “page not found” page are trying to direct me to a location within a non-existent folder named “blog”

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Did you correct the index.php in the root to have require('./wp/wp-blog-header.php'); ?

    If you view the source of it’s pointing to

    See the lack of the WP? THAT is why you cannot login. Your site thinks it’s installed one folder up, when it’s really not…

    Okay, let’s kick it. Put this in your wp-config.php

    define('WP_SITEURL', '');
    define('WP_HOME', '');

    (You did the uninstall correctly, the causality would be the whole ‘act in root’ thing, which doesn’t work with MultiSite, and installing it that way seems to have munged things badly.)

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Went Multisite, then changed my mind, now I can't get the wp-login to show’ is closed to new replies.