WordPress.org

Support

Support » How-To and Troubleshooting » Weired Problem: Auto Home Page Redirection!

Weired Problem: Auto Home Page Redirection!

  • ishan001
    Participant

    @ishan001

    I am having a weired problem at http://bloggingwithsuccess.net/

    I published a page http://bloggingwithsuccess.net/mail-terms-of-use and now, when I try to visit homepage, I automatically get redirected to this page.

    I tried changing homepage from WP Reading settings but no help. Then I disabled W3 Total Cache(I upgraded to dev version accidentally when plugin authors pushed wrong update!).I unpublished page but then it gave 404 errors! For now, I have put info about problems on homepage.

    How can I fix it?

Viewing 15 replies - 1 through 15 (of 15 total)
  • ishan001
    Participant

    @ishan001

    I am using Thesis 1.6!

    ishan001
    Participant

    @ishan001

    I have disabled all plugins! Still no luck!

    ishan001
    Participant

    @ishan001

    I even changed theme to default, still no luck!

    ishan001
    Participant

    @ishan001

    I have tried re-installing WP automatically, still no luck!

    I’m having the same problem. I’m using version 2.1.27 of the plugin and Thesis 1.7. Disabling the redirection plugin fixes the problem, but my redirects are broken.

    ishan001
    Participant

    @ishan001

    Well, looks like this is plugin issue. It worked fine for me after disabling redirection plugin!

    counterfill
    Participant

    @counterfill

    Since upgrading to WP 3.0, the root (/) or home page of the site is redirected to newly created pages.

    You can remove the redirection(s) by going to Tools > Redirection > Groups > Modified Posts and deleting the latest entry listed as “/” without quotes.

    My guess is this is a bug in plugin when running WP 3.0. This should be a good workaround until the author fixes it.

    michaelwillow
    Member

    @michaelwillow

    Same damn problem here
    The .htaccess rewrites are battling with my WordPress rewrites because there are bugs in this plugin. If I deactivate it, looks ok but I need it. So I would say better wait until the author will fix it.

    Very disappointed with wordpress 3
    Really sucks!!!

    Having the same problem, here’s what I’ve found:

    – When a new page is published, a redirection record is automatically inserted into the redirection_items table, redirecting the root URL to the new page

    – The new record is considered to be a “Modified Post” redirection, as opposed to a normal redirection. So make sure to change the Group dropdown to Modified Posts on the plugin settings page if you need to delete a rule

    – Workaround: save the page as a draft, then publish it

    Really weird. Glad I’m not the only one this happened to.

    Ben Huson
    Participant

    @husobj

    The other temporary fix which is slightly more practical is to disable URL monitoring.

    1. Go to Redirection > Options
    2. Set URL Monitoring to “Don’t Monitor” and Update your changes.
    3. Go to Groups > Modified posts and remove any that have been applied to the home page

    ishan001
    Participant

    @ishan001

    @ husobj

    Thanks. I use this plugin heavily for affiliate links and many other things and this fix is a life saver!

    clickstefan
    Member

    @clickstefan

    Sort of the same problem with RSEvents, the homepage gets redirected when the plugin is active, but in WordPress 2.92 … Apache ModRewrite is activated, and WordPress’s hompage redirect also.

    michaelwillow
    Member

    @michaelwillow

    I found husobj’s solution really effective. It works ok now

    Ahhh, thank you guys! This thread just saved my ass 🙂

    Eric Daams
    Participant

    @ericdaams

    I figured out how to fix the plugin. You can still keep the URL Monitoring working if you’re comfortable with some PHP hacking. Posted the solution over at http://wordpress.org/support/topic/422148?replies=14#post-1617309

    Cheers,
    Eric

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Weired Problem: Auto Home Page Redirection!’ is closed to new replies.