Support » Theme: Shoreditch » Weird XML sitemap for Shoreditch theme

Viewing 4 replies - 1 through 4 (of 4 total)
  • Jerrysarcastic

    (@jerrysarcastic)

    Hi there,

    The issue you describe is not due to your theme, but something that happens often with WordPress sites (regardless of the theme you are using) in cases where you publish a page that has no title.

    In this case I noticed that your page does not have a title, so by default WordPress will use it’s “page ID” in the permalink URL for the page. The ID for this page is 845, so that is why you see that in the URL you shared here.

    You should be able to resolve this issue simply by giving your page a title. If you are trying to have a page with no title but want to be able to customize the URL I recommend reaching out to the folks in the main WordPress troubleshooting forums here: https://wordpress.org/support/forum/how-to-and-troubleshooting/

    Hope this helps point you in the right direction!

    Thread Starter billbennett

    (@billbennett)

    Thanks Jerry

    I may have this wrong, but it looks to me like the problem IS specific to the Shoreditch theme. That’s because Shoreditch allows you to assemble a front page for a site by stitching together material from a series of pages.

    The text you place on a page… including the H1 text would be the page title, shows up on that front page, so unless you want multiple H1 headlines on a page you have no choice but to leave the title blank.

    Jerrysarcastic

    (@jerrysarcastic)

    That’s because Shoreditch allows you to assemble a front page for a site by stitching together material from a series of pages.

    You will notice on the theme demo here, each section has been given a title. Partners, Testimonials, Services, etc. https://wordpress.com/theme/shoreditch/rustedandchromed.wordpress.com

    You can see this echoed here in wp-admin, where you can see that each homepage section in the demo is a child page of home, with the titles clearly displayed. Screenshot here: https://d.pr/i/wQICtV

    Because each homepage section has it’s own title (which is displayed on the homepage for each section) that means that the individual pages have the correct permalink, so you have URLs like:
    https://shoreditchdemo.wordpress.com/home/partners/
    https://shoreditchdemo.wordpress.com/home/services/

    As you can see, the page URL for those is taken from the page title. And the opposite is true. If you do not add a page title (regardless of theme) WordPress does not know how to assign a standard permalink.

    The text you place on a page… including the H1 text would be the page title, shows up on that front page, so unless you want multiple H1 headlines on a page you have no choice but to leave the title blank.

    There is another option. What you can do instead is give each page a title (which is a best practice for SEO) and then use CSS to hide the titles so the don’t appear on the homepage. To do that, first give your sections a proper page title, which will fix the URL issue. Then use this CSS to hide the page titles so they don’t appear twice on the homepage:

    /* hide all but the first panel title on the front page*/
    .home .site-main article:not(:first-of-type) .entry-header .entry-title {
    	display: none;
    }

    Hope that helps!

    Thread Starter billbennett

    (@billbennett)

    Yes, this is exactly what was bothering me. Shoreditch is the idea theme for my purpose, but it can be a struggle to get your head around how this works when you’re not a developer.

    Thanks Jerry this has fixed it for me.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.