• Resolved Nina Harris

    (@ninaharris)


    Hello All,
    I’m new to WordPress. On my blog https://floridapsychics.org/ when I add a new link under Navigation it adds a weird url structure which is in this format.
    E.g. for /articles category it adds following url for the menu item if I select it automatically from drop down it shows during menu add
    https://floridapsychics.org/./articles

    I know I can edit the url but I wanted to know why it adds such url with “/./” in between instead of just “/”? Is it a bug? How can we fix it so that it only adds /

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator Kathryn Presner

    (@zoonini)

    Hi @ninaharris – I’m not sure why your links are showing like that in the navigation block, I’ve never seen that happen before 😉

    If this is still happening, would you mind recording a screencast of you going through the process of adding a navigation item, and posting it here? You could use https://www.loom.com or your preferred method, and post the link here.

    Could you also post a screenshot of your list of Pages in WP-Admin so I can check your page structure? You can use Snipboard or your preferred method, and post the link to the screenshot here.

    Thread Starter Nina Harris

    (@ninaharris)

    Hello Kat,
    Sorry it’s not the pages but the categories which are giving above url structure when I add categories in menu items. Here is the link to screenshot. Please see the highlighted section in red.

    View post on imgur.com

    Moderator Kathryn Presner

    (@zoonini)

    Hi @ninaharris – thanks for the screenshot! I’m not sure where that’s coming from but I doubt it’s theme-related, as the theme does not normally affect URLs, slugs, permalinks, or anything like that.

    I’d suggest you check your Permalink settings under Settings to see what your permalink structures are. You’re also welcome to post your question in the Fixing WordPress forum, where general questions like this go. 🙂

    Moderator Kathryn Presner

    (@zoonini)

    I’m marking this as resolved since it’s been a while since we’ve heard from you. If you need help with anything else, don’t hesitate to start a new thread.

    Thread Starter Nina Harris

    (@ninaharris)

    Hello Kathryn, I think I’ve managed to make it work. Thanks for the help.

    Moderator Kathryn Presner

    (@zoonini)

    Great, glad to hear you got it sorted. Feel free to share what the solution was, in case it helps others coming across this thread in the future. 🙂

    Thread Starter Nina Harris

    (@ninaharris)

    I don’t think it is a solution but I know where the issue is coming from. In Permalinks I always use . (dot) for Category base, this is the mysterious dot appearing in the link. When I remove dot and leave it empty it doesn’t show dot but it now shows /category/ so it is not exactly the solution as such.

    I’m not sure what is the right value for Category base for not showing word “category” in the URL. Do you know that? I always thought (since older WP versions) it has to be a dot.

    Moderator Kathryn Presner

    (@zoonini)

    @ninaharris Ah, thanks for clarifying your category permalink structure, that explains a lot. . has a particular meaning in file/URL structure – you can read more about it here if you’re interested in the technical details. 🙂

    If your aim is to remove the word “category” completely from category page paths, and you don’t want to replace it with another word, you can try a plugin like this one:

    https://wordpress.org/plugins/no-category-base-wpml/

    That should also get rid of the original menu link problem. Let me know how it goes!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Weird url in Navigation add item’ is closed to new replies.