Support » Fixing WordPress » Weird upload image problem

  • No plugins activated.
    Twenty Twelve theme activated.

    I upload test.jpg and set as the featured image on a page, everything seems fine.
    I look at the page and the alt text shows with a grey outline of an image but no image.
    I look at the source code being generated and it is trying to load “test.jpg”
    I go to my uploads folder, there is test-200×300.jpg and test-150×150.jpg but no test.jpg.

    It seems to me wordpress is not saving the original image, just generating a couple small thumbnails.

    If i go into the wordpress image gallery and edit test.jpg by rotating it, save. And then rotate it back to original position it creates new files in the upload directory and everything works great. However, I do not want to do that over and over.

    Any recommendations?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Have you tried uploading from the Post edit / add page? Or if you have tried that already, try uploading from the Media -> Add New page?

    I was adding the image while creating a new page.

    I tried what you said, media -> add new. I attempted to add a 220×330 image. My uploads folder created a 150×150 and a 200×300. I also added a 2480×3580 image and it created a 150×150, 212×300, 723×1024.

    I wonder why it’s not creating the full size image?

    No plugins activated.

    Do you have any inactive plugins? If you do, can you temporarily rename wp-content/plugins to something else?

    Also try to use a different theme.

    Do you have access to another WordPress setup? Are you able to reproduce the situation there?

    I AM using Multisite. In my Network Admin I have all plugins deactivated.

    I went ahead and renamed the plugins folder to “1plugins” (to ensure it cannot access them). Afterwards, I tried uploading an entirely different image. Same results.

    I unfortunately do not have access to any other WordPress servers. This server is hosted locally on my IIS7 server.

    I’m having the same issue on an IIS server. Did you ever get it resolved cerics?

    No I have not. I have many theories but no solid proof of what is causing it. I have found a work around to get the images to appear correct though. After uploading into the back end of wordpress, edit the image by rotating it left or right and then rotate it back to original. This saves the image correctly allowing to be used on the site.

    Feel free to ask any questions, I am busy working on several things but this is on my to do list for the near future and I would be happy to see it resolved.

    Okay I got it resolved. I finally found another blog with the answer. It has to do with the Authentication in IIS.

    Do this -> Internet Information Services (IIS) Manager –> Sites –> Your Site –> Authentication –> Anonymous Authentication –> Edit (on the right side)

    Instead of “Specific User” option, select “Application Pool Identity” option. I restarted the website and all is working again. Hope this helps.

    PS. I thought this was not going to solve the problem but it did.

    Amazing. It works! Thank you ipoint-tech you’ve solved my problem. I really appreciate it!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Weird upload image problem’ is closed to new replies.