WordPress.org

Support

Support » Installation » Weird Upgrade Error – Cannot redeclare wp_delete_link()

Weird Upgrade Error – Cannot redeclare wp_delete_link()

  • marksweb
    Member

    @marksweb

    Fatal error: Cannot redeclare wp_delete_link() (previously declared in /home/fhlinux176/m/marksweb.co.uk/user/htdocs/blog/wp-admin/admin-db.php:407) in /home/fhlinux176/m/marksweb.co.uk/user/htdocs/blog/wp-admin/includes/bookmark.php on line 41

    Any Ideas?
    Google doesn’t pick anything up 🙁
    I’ve just uploaded 2.3 files and ran the upgrade file.

Viewing 8 replies - 1 through 8 (of 8 total)
  • whooami
    Member

    @whooami

    you didnt delete the files from your old install before uploading the new files.

    2.3 doesnt have an wp-admin/admin-db.php

    marksweb
    Member

    @marksweb

    oh right, i don’t normally delete files – previous upgrades have all been fine by just overwriting :s

    anyway, thanks, i’ll del the dir and try again.

    whooami
    Member

    @whooami

    i do believe the instructions are clear 🙂

    MichaelH
    Member

    @michaelh

    matt created a new Upgrading WordPress that does not advocate deleting files, just overwriting them.

    For now, it might be better to use the instructions from Upgrading_WordPress_Extended–in particular Steps 7 and 8.

    whooami
    Member

    @whooami

    meh, and thats been shown over and over again not to work. bad advice if you ask me. That makes a lot of assumptions about how familiar one is with how to use their particular FTP client.

    ‘Cant wait to see the threads that show up here because of that.

    Who’s Matt?

    MichaelH
    Member

    @michaelh

    Matt Mullenweg

    whooami
    Member

    @whooami

    uh, I was joking.

    MichaelH
    Member

    @michaelh

    Oh I should have know that 😉

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Weird Upgrade Error – Cannot redeclare wp_delete_link()’ is closed to new replies.