WordPress.org

Support

Support » Installation » [Resolved] 2.5 Weird Problem: Unable to access the Dashboard homepage; rest all is fine

[Resolved] 2.5 Weird Problem: Unable to access the Dashboard homepage; rest all is fine

  • Hi,

    I have just upgraded my installation from WP2.3.3 to WP2.5 for the second time. I am facing a strange problem – my dashboard homepage is not accessible. I have already done two fresh upgrade installations, but this problem still persists. When I login from the admin page, I get this error:

    The error that I am getting is:
    Fatal error: Call to undefined function: wp_register_sidebar_widget() in /home/XXXX/blog.gagankaul.com/wp-admin/includes/dashboard.php on line 31

    I am able to access the dashboard by logging in and then going to a particular post on my blog and clicking on the edit post option. However, I cannot reach the Dashboard directly from the login page. Also, all other options are working fine. But when I click on Dashboard link from my administration panel, it shows the same error.

    Has anyone faced similar situation? I have searched the site but could not find anyone talking about this error. Maybe I am doing something wrong. Please help!

    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello…. no comments … can anyone help please?

    I have exactly the same problem. I’ve deactivated all plugins and this doesn’t help either. I use K2 as a theme.

    max

    This is a long shot for you, but I started having problems using FF 1.0.7 with WP 2.5. After I got a newer version of Firefox the problem went away. Since I have the different versions of FF in different named folders, I was able to go back and check using the older version. Hiccups again.

    Both versions view my blogs fine. Its when I’m in WP 2.5 admin panels that I have problems.

    I think the problem is with K2. When I switched to default theme the dashboard worked.

    max

    I am using K2 as well. I have tried switching back to the default theme. But I am still getting the same error. Did anyone else face the same problem with the K2 theme?

    Did you upgrade the default theme?
    By me with the default theme the dashboard works as it should and with K2 I have exactly the same problem as you.

    max

    Thanks maxiu. It is working for me now with the default theme. I think there are some compatibility issues with the K2 theme, because of which we are getting this error.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] 2.5 Weird Problem: Unable to access the Dashboard homepage; rest all is fine’ is closed to new replies.
Skip to toolbar