Support » Plugin: AddToAny Share Buttons » Weird problem about showing icons

  • Resolved fran330

    (@fran330)


    Hello,

    On this website, I use Addtoany Share and Follow widgets, on the right side of the site.

    – when I check Advanced options/Cache AddToAny locally with daily cache updates, the Addtoany icons show on Windows and Android divices but they don’t show on Apple divices (computer and mobile)
    It’s the case with the French subsite: https://fr.yoga-laurence-lhermitte.com/
    – when I uncheck that option, it’s the opposite: the icons show on Apple devices but they don’t on Windows or Android devices.
    It’s the case with the English subsite: https://en.yoga-laurence-lhermitte.com/

    I made the following tests:
    – I set the theme to Twenty Twelve
    – I disabled all plugins except Addtoany
    None of this helps. The problem is the same.

    Note that I don’t encounter this problem on my other websites although most of them are built more or less the same as this one.

    Can you help?
    If you need more info, please let me know.
    Thanks in advance,
    Fran

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author micropat

    (@micropat)

    Hi Fran, thanks for your perfect initial troubleshooting.

    On the French site, the server is struggling to serve the locally cached file(s):
    https://fr.[your-site].com/files/addtoany/page.js
    https://fr.[your-site].com/files/addtoany/icons.28.svg.css

    The files are each taking over 5 seconds to download, and some browsers such as Safari will timeout before that long.

    Only image files are served as fast as expected from there, e.g.:
    https://fr.[your-site].com/files/addtoany/icons.36.png

    The extent of the plugin’s local cache feature is to save/update the file once a day in the site’s uploads directory, and then to use it live. How the file is served is completely up the site’s server, and it usually serves just fine on servers (although not as fast as the AddToAny CDN).

    You should look into why your server is struggling to serve non-image files from its /files/ upload directory. It might be doing something like on-the-fly “gzip” compression for such text-based files. Your .htaccess files could offer some clues. Ask your host for some insight if needed.

    Regarding the English site, the buttons are definitely loading for others on Windows and Android. It’s likely that you have a content blocker enabled on your devices or connections, such as an ad blocker that optionally blocks social buttons.

Viewing 1 replies (of 1 total)
  • The topic ‘Weird problem about showing icons’ is closed to new replies.