Support » Installing WordPress » Weird PHP version conflict please help!

  • I tried installing wordpress today and when I accesed my wp-admin/install.php
    I got this message:

    Your server is running PHP version 4.4.9 but WordPress 3.2.1 requires at least 5.2.4.

    Whats weird is I checked my server and I am running version 5.2.6

    So Im confused as to why I still get this message. Help anyone?
    Thanks.

Viewing 14 replies - 1 through 14 (of 14 total)
  • esmi

    (@esmi)

    Forum Moderator

    Check the PHP version with your hosts.

    I had the same problem; cPanel was reporting version 5.2.14 but on my host, even though PHP5 was available, I had to specify that I wanted to upgrade to PHP5. Until I did that, I was actually still using version 4.4.9. You may be able to switch to PHP5 using cPanel, or by adding lines to your .htaccess file—in my case I needed to add the following:

    AddHandler application/x-httpd-php5 .php5 .php4 .php .php3 .php2 .phtml
    AddType application/x-httpd-php5 .php5 .php4 .php .php3 .php2 .phtml

    Yes indeed I had already done that yesterday before writing this. I even called my service provider and they re-checked that I had PHP5.
    I got frustrated and went to bed. Today I try to access wp-admin/install.php and I get an “ACCESS DENIED” message.
    ?
    Im lost. Dont know why its acting up like this. Thing is I already tried deleting everything and installing again last night and nothing changed

    esmi

    (@esmi)

    Forum Moderator

    Contact your hosts. The “ACCESS DENIED” message is not coming from WordPress.

    Try adding the following to .htaccess if you are hosting with 1and1.com:

    AddType x-mapp-php5 .php

    I had to reply to this…i just wasted 2 1/2 hours searching, and making, renaming .htaccess a million times, via 1&1 web space access, and filezilla.
    What worked for me, i just deleted me .htaccess file in my root folder, where the index.php folder is.

    then, in the 1&1 control panel, under “Domains and Web Space” then under “Web Space” go to the link “Global PHP Version” then change it to “php5”

    This was for 1&1 Home Linux hosting.
    Good Luck. Hopefully it wont take you as long it did for me

    I had this same problem. I followed the advice of djciscoelnino and recovered my main blog page, but the individual post pages are now 404s. Anyone have any ideas?

    Nevermind. The htmaccess file needed to be rebuilt and I just needed to save my permalink settings.

    Thank you djciscoelnino!!!!! All fixed and ready to go!

    I had to reply to this…i just wasted 2 1/2 hours searching, and making, renaming .htaccess a million times, via 1&1 web space access, and filezilla.
    What worked for me, i just deleted me .htaccess file in my root folder, where the index.php folder is.

    then, in the 1&1 control panel, under “Domains and Web Space” then under “Web Space” go to the link “Global PHP Version” then change it to “php5”

    This was for 1&1 Home Linux hosting.
    Good Luck. Hopefully it wont take you as long it did for me

    Its giving me a lot of problems also, it says “ACCESS DENIED”…

    esmi

    (@esmi)

    Forum Moderator

    Please post a new topic.

    Try adding the following to .htaccess if you are hosting with 1and1.com:

    AddType x-mapp-php5 .php

    Had the same problem as the original poster and this solution worked for me; thanks.

    Hello there, I just made the terrible mistake of upgrading wordpress when my site was working just fine, and now I can no longer access my control panel. I get this message each time I try to log in: Your server is running PHP version 4.3.11 but WordPress 3.2.1 requires at least 5.2.4.

    My site is hosted by Yahoo and they tell me because I manually uploaded the new wordpress using cyberduck, I overwrote all their controls and now there is nothing they can do except direct me to wordpress. They say Yahoo does not support PHP 5 and up, only 4, but even though I have now switched back to PHP version 4.3.11, I still cannot access my control panel.

    So now I can see and view my site, as long as I remove the ‘/blog’ from the url. If I include it, I get just a blank white page. When I remove the /blog, I can view my page fine, but when I click log in, I get the Your server is running PHP version 4.3.11 but WordPress 3.2.1 requires at least 5.2.4. messsage.

    Appreciate any advice of help.

    Moderator Mark Ratledge

    (@songdogtech)

    Forum Moderator

    You can upload all core WP files from the older version you upgraded from, but the problem is the database was probably upgraded in the process, so you will probably get errors.

    Older versions available at Release Archive

    If not, find a new host. Yahoo is pretty bad.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Weird PHP version conflict please help!’ is closed to new replies.