Support » Fixing WordPress » Weird Periodic 302 Redirects Going On

  • joshuas

    (@joshuas)


    I am experiencing a strange phenomenon and hoping someone here has some insight. I was informed by Google Webmaster tools that there was a redirect error on this page http://www.cmxmetals.com/ecobrass/

    When I first load the page using the FF live headers plugin I see the following:

    http://www.cmxmetals.com/ecobrass/
    
    GET /ecobrass/ HTTP/1.1
    Host: www.cmxmetals.com
    User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-us,en;q=0.5
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 300
    Connection: keep-alive
    Cookie:
    
    HTTP/1.x 302 Moved Temporarily
    Content-Length: 0
    Location: /ecobrass/?8f68abd0
    ----------------------------------------------------------
    http://www.cmxmetals.com/ecobrass/?8f68abd0
    
    GET /ecobrass/?8f68abd0 HTTP/1.1
    Host: www.cmxmetals.com
    User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-us,en;q=0.5
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 300
    Connection: keep-alive
    Cookie: 
    
    HTTP/1.x 302 Moved Temporarily
    Content-Length: 0
    Location: /ecobrass/
    ----------------------------------------------------------
    http://www.cmxmetals.com/ecobrass/
    
    GET /ecobrass/ HTTP/1.1
    Host: www.cmxmetals.com
    User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-us,en;q=0.5
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 300
    Connection: keep-alive
    Cookie: 
    
    HTTP/1.x 200 OK
    Date: Thu, 17 Sep 2009 18:50:57 GMT
    Server: Apache
    X-Pingback: http://www.cmxmetals.com/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Last-Modified: Thu, 17 Sep 2009 18:51:06 GMT
    Cache-Control: no-cache, must-revalidate, max-age=0
    Pragma: no-cache
    Keep-Alive: timeout=15, max=100
    Connection: Keep-Alive
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=UTF-8

    Then when I try loading that page immediately after it produces a 200:

    http://www.cmxmetals.com/ecobrass/
    
    GET /ecobrass/ HTTP/1.1
    Host: www.cmxmetals.com
    User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-us,en;q=0.5
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 300
    Connection: keep-alive
    Cookie:
    If-Modified-Since: Thu, 17 Sep 2009 18:51:06 GMT
    
    HTTP/1.x 200 OK
    Date: Thu, 17 Sep 2009 18:54:58 GMT
    Server: Apache
    X-Pingback: http://www.cmxmetals.com/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Last-Modified: Thu, 17 Sep 2009 18:55:02 GMT
    Cache-Control: no-cache, must-revalidate, max-age=0
    Pragma: no-cache
    Keep-Alive: timeout=15, max=100
    Connection: Keep-Alive
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=UTF-8

    This happens with other pages as well and can be confirmed with other header checkers (the page will be 302 redirected to same url with a query string appended). If anyone has any ideas on what might be causing this it would be much appreciated. Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • joshuas

    (@joshuas)

    wow, that post dropped like a log.. anyone??

    iridiax

    (@iridiax)

    Are you using some sort of stat or link tracking code/app? If you are getting this with everything, you should check with your web host.

    joshuas

    (@joshuas)

    I checked the log files and the redirects seem to be associated with the stylesheets. Can that possibly be related?

    joshuas

    (@joshuas)

    Host is Godaddy… Got the typical canned response that they don’t support 3rd party scripts so no help there.

    Same problem here – Google webmaster tools not accepting the sitemap – same strange redirects.

    Would appreciate help from anyone – HAAALPP!

    Also, why do you feel that it’s a stylesheet problem?

    I called godaddy support – the guy was helpful and saw the problem, but had no clue what was going on.

    But try this.

    Rename your .htaccess file to something else. Then request a post with a pretty permalink which should then return an error. Rename your .htaccess file back and see if the problem is still there…

    Just a shot in the dark.

    I was having the exact same issues.

    I worked through what I did to get to a what I’m guessing to be a temporary solution. I don’t think I resolved it long term however.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Weird Periodic 302 Redirects Going On’ is closed to new replies.