WordPress.org

Support

Support » How-To and Troubleshooting » Weird links below each post…..

Weird links below each post…..

  • boriskamp1991
    Member

    @boriskamp1991

    Today I started setting up a newsletter for my website and noticed something strange in my RSS feed.

    at the bottom of each post there is automatically generated link that I cant seem to trace.
    I want to get rid of it, do you guys have any idea?????
    Here is my RSS feed so you can check it out

    thanks!

Viewing 15 replies - 1 through 15 (of 19 total)
  • Are you using any image/ photo plugins?

    boriskamp1991
    Member

    @boriskamp1991

    Yes, I am usimg fancybox and nedtgen gallery.
    Thank you for your reply

    Boris

    Can you turn of the plugins and see if the links are still there?

    boriskamp1991
    Member

    @boriskamp1991

    I turned it off, but nothing changed.
    When I view my posts ON my site, I cant see the link a the bottm of the page.
    It is onl visable in the rss feed.

    Any suggestions anyone?
    Thanks

    I find base64 codes in your site which can perhaps be causing the trouble. See the validation report here, though I am not sure if they are malicious.

    boriskamp1991
    Member

    @boriskamp1991

    Thank you for your help krishna, but the link you gave me is like magic to me, can you find the error in the report? And what I should change?

    You may go through line 327 of the above and other links below. Probably the base64 code is being injected by the plugin widgetkit. You may delete it and see what happens, though there can be other sources of the code.

    boriskamp1991
    Member

    @boriskamp1991

    thank you for your suggestion,
    Disabling widgetkit doesnt seem to change it (cleared my cache after)
    I cant see any link below your post (you last post)
    and line 327 is empty? or am I missing something?

    thanks for your help!

    You won’t find it now (I posted it two days ago). Now I get this error:
    500 Can't connect to 'http::80 (Bad hostname ''http:') when I tried to get a new report. Maybe, disabling widgetkit could have changed it.

    Anyway, check up if you get the same error?

    boriskamp1991
    Member

    @boriskamp1991

    I get this:

    HTML5 Validator Error ✉
    Line 273, column 140: An a start tag seen but an element of the same type was already open.
    …http://www.militaryscalemodelling.com"><img src="http://www.militaryscalemodel…
    Line 273, column 140: End tag a violates nesting rules.
    …http://www.militaryscalemodelling.com"><img src="http://www.militaryscalemodel…
    Line 273, column 140: Cannot recover after last error. Any further errors will be ignored.
    …http://www.militaryscalemodelling.com"><img src="http://www.militaryscalemodel…

    the link works on my side right?

    I think most of the earlier problems are over now. What problems do you find now?

    boriskamp1991
    Member

    @boriskamp1991

    well, I still got the problem as described in teh first post:

    at the bottom of each post there is automatically generated link that I cant seem to trace.
    I want to get rid of it, do you guys have any idea?????
    Here is my RSS feed so you can check it out

    check out my rss feed, and check the bottom of each post.

    Now I find malicious code (phishing) hosted in your site. See line 375 of your validation report.

    Earlier you had base64 as I pointed out.

    Here is what you need to do. Follow all the steps as in the case of a hacked site. I would not hesitate to say your site is hacked, sorry.

    Here is what you need to do:
    http://codex.wordpress.org/FAQ_My_site_was_hacked

    Good Luck!

    boriskamp1991
    Member

    @boriskamp1991

    Thanks again!
    but what is the problem? line 375 is my twitter update right?
    was a bit shocked still, so I did change my secret keys and password just to be sure.

    Do you find something like this -- t.co/krpDMMLh-- (not complete URL) in the string starting with line 375? If so copy the URL correctly from there and test it here: http://sitecheck.sucuri.net/scanner/

    or using some other security scanners.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Weird links below each post…..’ is closed to new replies.