WordPress.org

Support

Support » How-To and Troubleshooting » Weird htaccess issue?

Weird htaccess issue?

  • Hi all,

    I upgraded to WP2 about two weeks ago now but have been having sporadic problems with a particular plugin related to htaccess (I think). I use the FAlbum plugin to display my flickr photosets and pics within my site (Linky) but since the upgrade some users have been reporting 404s when browsing the sections of the site controlled by FAlbum.

    Since WP2 handles the htaccess rules differently, I moved the FAlbum htaccess instructions above the WordPress ones as below:

    # BEGIN FAlbum
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule ^photos/?([^/]*)?/?([^/]*)?/?([^/]*)?/?([^/]*)?/?([^/]*)?/?([^/]*)?/?([^/]*)?/?([^/]*)?/?$ /wp-content/plugins/falbum/falbum-wp.php?$1=$2&$3=$4&$5=$6&$7=$8 [QSA,L]
    </IfModule>
    # END FAlbum
    RedirectMatch temp ^/blog$ http://www.anthonymcg.com
    RedirectMatch temp ^/blog/$ http://www.anthonymcg.com
    ErrorDocument 404 /index.php?error=404
    RedirectMatch temp ^/gallery.php$ http://www.anthonymcg.com/photos/
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>
    # END WordPress

    I’ve tried the FAlbum forums and haven’t got much luck so I’d appreciate some help if there’s anyone out there familiar with things like this. Thanks a million.

    Anthony

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Weird htaccess issue?’ is closed to new replies.
Skip to toolbar