Support » Plugin: Breeze - WordPress Cache Plugin » Weird Homepage Caching on Safari and Firefox

  • handmadehome

    (@handmadehome)


    Hi,
    Can you help me, please?

    BREEZE CACHING WORKS IN DIFFERENT WAYS ON CHROME AND SAFARI+FIREFOX

    That causes wrong information on Safari and Firefox. Looks like the cache gets stuck on Safari and Firefox. But at the same time, it works correctly on Chrome.
    I want additionally to draw your attention to that this bug appears ONLY on the HOMEPAGE of website. Rest pages of website cached correctly in ALL browsers.

    So, ONLY HOMEPAGE AND ONLY ON SAFARI AND FIREFOX cached this weird way. But at the same time Chrome displays all correctly.

    Please, how can I fix this disparity? I NEED AN IDENTICAL HOMEPAGE IN ALL BROWSERS. I want Safari and Firefox to provide the same homepage as Chrome.

    This is Chrome (correct homepage)
    Chrome

    And this is how homepage looks on Safari and Firefox:
    Safari

    I tested plugin conflicts. The root of the problem is Breeze. If I deactivate Breeze the issue disappears. (I can also use “Purge internal cache” in setting to bring in line my homepage on safari and firefox. But this is a bad decision. Otherwise, I need to purge the cache endlessly.)

    I have only Woocommerce and Breeze plugins enabled now. Varnish, Redis+Object cache are disabled.

    Thank you!

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author adeelkhan

    (@adeelkhan)

    I have captured videos on safari and Firefox both work perfectly.
    Please have a look

    Firefox: https://wordpress-419414-1340941.cloudwaysapps.com/wp-content/uploads/2022/02/Fire-fox.mp4

    Safari: https://wordpress-419414-1340941.cloudwaysapps.com/wp-content/uploads/2022/02/safari.mp4

    Could you please check on on different device?

    Thread Starter handmadehome

    (@handmadehome)

    Thank you for the videos! They are very helpful!
    Can you see pink “Read more” buttons on your video? And now, please take look at my first message. You should see blue “Add to cart” buttons on my website. If you check on Chrome you will see them. And this will be a correct version. Only chrome displays the correct version.

    Plugin Author adeelkhan

    (@adeelkhan)

    You are always welcome.
    As I capture the screenshot on chrome browser I still get the same response as Firefox and safari.
    Please have a look.
    https://wordpress-419414-1340941.cloudwaysapps.com/wp-content/uploads/2022/02/chrome.png

    Thread Starter handmadehome

    (@handmadehome)

    Hmm, Now I completely can’t understand what is going on…

    On my end I see blue Add to cart button on Chrome:
    Chrome

    How can I fix the issue? I should have blue “Add to cart ” instead of pink “Read more” on ALL browsers. All pages of website work well but homepage.

    This issue is bother me. The homepage is important. Because of homepage cache works this way I have outdated stock status for products. Product status on homepage says In Stock when it actually Sold and so on. It’s confusing. I can disable Breeze, so you will see the difference. Please, let me know if I need to do this.

    Thanks!

    Thread Starter handmadehome

    (@handmadehome)

    I decided not to wait:) Breeze is deactivated

    Plugin Author adeelkhan

    (@adeelkhan)

    Sorry for the inconvenience, it would be possible there is a conflict with the activated theme and plugins.
    Could you please check by disabling the plugins except for breeze as well as verify if there is any console error in the Network tab?

    Thread Starter handmadehome

    (@handmadehome)

    I received a message from breeze developer saying that I need to contact via email. Can you, please, confirm that you received my email. I sent it several days ago. Thanks!

    • This reply was modified 8 months, 3 weeks ago by handmadehome.
    Plugin Author adeelkhan

    (@adeelkhan)

    Hi
    Basically, the point you raised is the need to investigate the actual point of conflict.
    Most probably it’s a conflict about the activated theme/plugins.
    First, you confirm did you apply the above-mentioned solution?
    if not so kindly apply and still, you find an issue so kindly contact our support team to investigate. Once get the conflict then share it on the ongoing thread for other users. In this forum, we guide our users according to the forum guideline

    Forum Guidelines

    • This reply was modified 8 months, 3 weeks ago by adeelkhan.
    Thread Starter handmadehome

    (@handmadehome)

    I’ve tested plugin conflicts. As I already wrote I have only Woocommerce and Breeze plugins enabled now. (Varnish, Redis+Object cache are disabled.)
    I use Storefront theme.

    When I deactivate Breeze the issue disappears. So probably something between Breeze and Woocommerce or Storefront heme causes this issue. But what can I do? I can’t disable woocommerce or storefront… I can only stop using Breeze.

    And I’m sorry, but you didn’t asked my question. Do I understand right that your developer changed his mind and I shouldn’t wait that he back to me with any support? I was asked WP Admin creditentials to my staging website. So I will close them if so.

    Plugin Author adeelkhan

    (@adeelkhan)

    We tried to replicate the issue as per your described scenario with Breeze+WooCommerce+Storefront but were not able to replicate it.
    Could you please contact a support team with the ref of the current thread?
    The breeze development team takes care of it and shares points of conflict ASAP.

    • This reply was modified 8 months, 3 weeks ago by adeelkhan.
Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Weird Homepage Caching on Safari and Firefox’ is closed to new replies.