Support » Plugins and Hacks » [Resolved] weird error message when updating jetpack comments page

[Resolved] weird error message when updating jetpack comments page

  • I get the following error message whenever I update the page with the jetpack comments form on it:

    “Warning: Cannot modify header information – headers already sent by (output started at /home/mizpat/public_html/wp-includes/class.wp-styles.php:92) in /home/mizpat/public_html/wp-includes/pluggable.php on line 881”

    Nothing seems to be broken on the page or the site, and my edits are always saved. I just get this strange message in the browser – nothing else on the page, just this message.

    I might have started getting it when I first tried to edit the contact form’s code in the Visual Editor, which I’ve done several times since then. I edited the code because I didn’t see any other way to edit once the form is created (tips are welcome on this too!).

    But again, nothing seems to be broken, and the contact form works fine. I don’t like getting error messages, though, since it usually means something’s broken or about to break.

    Thanks for any/all advice.


Viewing 5 replies - 1 through 5 (of 5 total)
  • You may try this:

    Look for white space (empty space) in the first file mentioned (class.wp-styles.php).

    Thanks, @krishna, I will check it out. pluggable.php is not my file – I don’t know whose it is, possibly a plugin? or WordPress?

    Anyway, I will post results when I can get to it.

    You have to use FTP or cPanel to go to WordPress > wp-includes in which you can find the file named pluggable. Download it and check for white/empty space at the beginning as well as at the end after opening it in a plain text editor (ex: notepad). As you cannot see any thing, you have to place the cursor at the beginning and end and use backspace and delete for a few seconds. Just try it. Alternatively, you can replace the current file from a fresh download of the version of WP you are using.

    Unfortunately that did not work, nor did the fresh download of 3.4.2. The strange thing too is that there is no ?> at the end of the pluggable.php file, even in the fresh download.

    Thanks for your help anyway. I appreciate it.

    The strange thing too is that there is no ?>

    It is not strange. It is left that way knowingly for some reasons. In fact the closing ?> is not required as per php guidelines.

    The last line is endif;. You can place the cursor between f and ; press delete for about 15 seconds, type only ; and save once only without touching any other keys and re-upload the file.

    If the above fails, delete the plugin so that the problem will be solved. You may reinstall it after solving the problem.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] weird error message when updating jetpack comments page’ is closed to new replies.