[resolved] Weird dash before title (also from Backend) (8 posts)

  1. Carlo Rizzante
    Posted 2 years ago #

    I am having a weird problem with the title of a site, part of a Multisite, the link here below:

    Before the title I have a dash. That character does not appear anywhere in the code. I looked up also in the database via phpMyAdmin. There is no dash there. Nonetheless, the dash is persistent even if I change the theme, or if I change the name of the site from the site Dashboard/Settings, or from the Network Admin > Sites/Edit/Settings, and so on.

    If you take a look at the markup, the dash overlap the tag of the title. I try to make an example here: <title≥La bellezza... </title> Indeed it is quite an interesting weirdo.

    Same happens for <h1≥La bellezza... </h1>, and everywhere there is the title. So far it happens with every browser I tried, Safari, Chrome and Firefox (all at the most recent releases).

    I really have no idea where this weirdo comes from... x_x Any clue?

  2. kmessinger
    Forum Moderator
    Posted 2 years ago #

    I see this
    CSS3111: @font-face encountered unknown error.
    Line 14, Column 69: Text run starts with a composing character. <title>̵La Bellezza salverà il Mondo | Pensieri di Caterina Fioretti</title>
    ̵La Bellezza salverà il Mondo

    Have you tried a different font?

  3. Carlo Rizzante
    Posted 2 years ago #

    Hello Kmessinger,
    thanks for your prompt reply. Following your suggestion, I tried right now to change font, but the weirdo doesn't resolve. Indeed, it is present also if I change theme, which made me wonder if it could be in the database.

    But in the database all seems ok.

  4. kmessinger
    Forum Moderator
    Posted 2 years ago #

    You can always run a repair on the database files and see if that helps.

  5. Carlo Rizzante
    Posted 2 years ago #

    Done, setting up define('WP_ALLOW_REPAIR', true); in wp-config.php but with no luck.

    Or do you suggest to repair with some plugin or other tools?

  6. Carlo Rizzante
    Posted 2 years ago #

    Ok, I have no idea what was that, but now it disappeared.

    I changed the title of the site, once again, from the Dashboard>Settings>Site Title. I deleted the "La" in the beginning. Saved, and then added again.

    And now it is fine.

    For the record, at some point, all sites in the network had a dash preceding the title, in every sections, even in the Backend and in the title of the Browser's Tab. The weirdo stayed for few refreshes, then disappeared by itself, and persisted only on the site we were speaking at first.

    Anyway, right now it seems it is resolved.

    Thank you very much for your support. Ciao!

  7. kmessinger
    Forum Moderator
    Posted 2 years ago #


  8. Carlo Rizzante
    Posted 2 years ago #


Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.