WordPress Popular Posts
[resolved] Weird character before excerpt (2 posts)

  1. nekoime
    Posted 1 year ago #

    I am not sure what title to give to this topic, so i apologize.

    I am having WP blog running customized theme, and i installed WordPress Popular Post Plugin. It works as it should, but just after the link, it displays weird character that shouldnt be there ":". It looks like this:

    Post Title Link
    <span class="wpp-excerpt">This is post excrpt bla bla</span>

    I really dont have any idea why it is showing there.If anybody have any suggestion/advice, i would be very grateful. http://goo.gl/9iJDvf is the link , Top Section in the right sidebar

    Original plugin code hasnt been touched if that helps...


  2. Hector Cabrera
    Plugin Author

    Posted 1 year ago #

    Hi there,

    The colon character (":") is part of the excerpt, actually. When I added the excerpt feature, the colon character was supposed to separate the title from the rest of the text. Of course, it doesn't look good in cases like yours (which I didn't think of back then).

    Simple, quick workaround:

    1. Go to the Widgets screen.
    2. In the WPP widget settings, find and enable the "Use custom HTML Markup" option.
    3. Set Post HTML Markup to: <li>{thumb} {title} <span class="wpp-excerpt">{excerpt}</span> <span class="wpp-stats">{stats}</span></li>.
    4. Save changes.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress Popular Posts
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic