[resolved] Weird! Can't add "/etc/" to any post. (6 posts)

  1. enli
    Posted 5 years ago #

    I am trying to update one of my article at http://enli.co.cc/tutorials/how-to-install-anything-in-ubuntu-a-compilation/ but I get redirected to 404 page with title of the page "Nothing found for wp-admin post php". I tried numerous suggestions from many sources but nothing worked.

    So I spent an hour figuring out for which text portion I get this error. Apparently if any of my posts contain "/etc/" I get above 404 error. For other variations of text e.g. "/ etc/" or "/etc /" the posts get published as they should.

    What could be causing this? I recently changed my host, could it be because of some module security?

  2. cubecolour
    Posted 5 years ago #

    I can't reproduce this, but to track down the cause you could temporarily disable all plugins to see whether that is the cause.

    As a workaround, does it work if you you the html character code for the slashes?
    & #47;

  3. enli
    Posted 5 years ago #

    html code didn't work. Although, "/et/", "/etb/", "/etcc/", "/xyz.../" work but not "/etc/".

    I just disabled all plugins, the problem still persist. I am assuming this has to do with something on host's side and not with the wordpress. Any guesses?

  4. It may be server-side security software, like mod_security, preventing certain things from being passed by the POST command, which WordPress uses to write to the database when publishing or editing a post.

  5. enli
    Posted 5 years ago #

    It indeed was related to mod_security. My host whitelisted the domain as suggested at http://baier.com/2009/09/wordpress-error-nothing-found-for-wp-admin-post-php/

    Marking thread as Resolved. Thanks for the hints.

  6. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic