Support » Fixing WordPress » Weird Caching Issue/Two Domains, not MU

  • Resolved aquagrrl


    I’m running into a weird caching issue. I have my domain setup so that three domains point to it; they are set up to do this via DNS; not redirects as I want them somewhat regionalized.
    The domains are (the domain in wordpress settings) and

    I made this work more or less by adding:
    remove_action(‘template_redirect’, ‘redirect_canonical’);
    to the functions.php file.

    It seemed to be working just fine – I had to used the root domain for wp-admin, but othewise it seemed to be working. Well, I updated the index yesterday (which is a page), and it won’t show up. I had wp-caching turned on, figured that was the problem and disabled. Still no luck. The wp-caching was in the htaccess file even though I had disabled, so I manually removed; still no changes. I’m out of ideas, I have no idea why it might still be showing the old page on the but the correct updated information on .com

    This is not running multisite (MU). I know that it’s one of those things that is a bit of a hack, but I think by all accounts it should be working and just really am flustered that it’s giving different pages.

    BTW, if you are looking for the difference, look for an entry for Mike Daly – it’s there on the .com but not the

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi!
    both versions of the site appear to be showing the exact same content, including the Mike Daly part.
    Did you figure this out already?
    If so, could you please share how you did it and mark the thread as resolved (only you can do the latter)?

    Yes, I figured it out. Even though I deactivated WP-caching and removed wp-caching info from the .htaccess, the cache files were still in the cache folder. I took a guess that it was reading from there and deleted them all. Sure enough, it fixed the problem. Sorry for not responding back but it’s working now.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Weird Caching Issue/Two Domains, not MU’ is closed to new replies.