Support » Fixing WordPress » WebSocket connection failed: newest-note-data errors ??

  • Resolved Tom

    (@tom-who)



    Hi! I am getting the following error reported by my WordPress blog:

    WebSocket connection to ‘wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data’ failed: Unexpected response code: 403

    The error is reproduced every minute or so. Here’s one blog (not yet active) that is producing that error: http://kultureshock.org.

    I’ve already tried turning off all plugins, but the error keeps happening. I have a multi-site setup using the WordPress MU Domain Mapping plugin. I did not turn this plugin off because I’m worried it’ll make a mess of things even if I turn it back on, but as some sites are not producing the error with this plugin active, I don’t think it’s causing the problem.

    Here is one of my multi-site blogs that is not producing this error: http://www.falsecreeekresidents.org.

    I cannot figure out what is generating this error on some of my WordPress sites but not on others. I have no idea what newest-note-data is. Is it part of the core functionality of WordPress? What response is it expecting?

    Any help in stopping these errors would be appreciated, thank you!

    Tom

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi Tom,

    I wasn’t able to reproduce what you’re seeing at http://kultureshock.org/ using Mac Chrome 50.0.2661.94 (64-bit) nor Mac Firefox 46.0. Can you provide the exact steps required to reproduce the issue please? Moreover, after completely wiping your browser’s cache, are you still able to reproduce the issue yourself? And, if so, what operating system/browser/browser version are you using to reproduce the issue?

    P.S., There’s a extra e in your False Creek URL. Here’s the one that worked for me http://www.falsecreekresidents.org/. 🙂

    Hope this helps!

    Hi Randy,

    Oops, sorry about the extra e in that domain!

    You are right, the error is not showing up in Mac Chrome or Mac Firefox when I checked it as well. It appears to be only showing up in Safari (9.1). I tried emptying the browser cache and restarting Safari, but the error persists only there. I’m running OS X El Capitan 10.11.14 on my MacBook and iMac (it shows up on both computers).

    I tried disabling all Safari extensions, no difference. When I disabled Javascript in Safari, the error appears to disappear from the console. But then on another blog (http://blog.kultureshock.net) which is also hosted within the same WordPress installation as the ones I linked to above, the error appears only when I click into a blog post, not on the index page. Which is very odd!

    So maybe this is just an issue with Safari and nothing to do with WordPress? I tried visiting a few other websites (with Javascript enabled) and could not see that same error in Safari, including the GeneratePress demo site, which is the template being used on that Kulture Shock blog. http://demo.generatepress.com.

    It’s a complete mystery! It only appears on a few of my WordPress sites and only in Safari, but not always if Javascript is disabled. ¯\_(ツ)_/¯

    Hi Tom,

    I could not reproduce the issue using Mac Safari 9.1 on OS X 10.11.4. The Steps to reproduce I followed where:

    1. Go to http://kultureshock.org
    2. Click on Hello World! link

    Result:
    Didn’t see the “WebSocket connection ….” error message on the home page nor on the post (i.e., http://kultureshock.org/2013/01/21/hello-world/) page.

    So, you wiped your Safari browser on both your macs as well as disabled ALL Safari extensions and yet you still see this error message, right? Very odd! Hmm, what did you mean when you said, “The error is reproduced every minute or so.” That is, for you, is the problem 100 percent reproducible or is it intermittent? Oh, and where on the web page is the error message displayed?

    P.S., Normally if the issue occurs on more than one computer I figure it’s not the particular user’s account setup. But given the way user prefs get copied around these days I can no longer think that way. Thus, do me a favor and create a new user that isn’t connected to your iCloud account on one of your macs and retest.

    Ah ha! If I Show Error Console on Safari I see “JQMIGRATE: Migrate is installed, version 1.4.0”. Which is something this support ticket is complaining about as well as mentioning the SAME error message:

    Re-order Fields via drag-and-drop not working

    And this ticket talks about in depth:

    http://wordpress.stackexchange.com/questions/224661/annoying-jqmigrate-migrate-is-in-console-after-update-to-wp-4-5

    Hi Randy,

    The error shows up in the Web Inspector console within Safari. I click on the Develop menu in Safari then click on Show Error Console.

    Yes, I emptied the cache and disabled extensions in Safari on both computers, but the error still appears. By reproduced, I mean that the error keeps happening every minute or so, as though whatever is causing the error keeps trying to connect to something.

    Okay, so I used the Guest account on my iMac and when I went to the website, the error doesn’t appear! A different one does about JQMIGRATE, but, the WebSocket error isn’t there. So this must be something in my setup of Safari causing this when viewing some of my WordPress sites. I’ll have to do more digging to see if I can find out what it is.

    Thanks very much for your help!

    Hi Randy,

    Just saw your followup reply after sending my reply above. I went to that thread you linked to and saw that it seemed to be related to the Woo Commerce plugin. I had just installed it yesterday, but hadn’t activated it for any sites yet. So I tried deleting the plugin completely and low and behold, that WebSocket error message is no longer showing!

    That is very strange being that the plugin wasn’t actually being used on any of my WordPress sites and was deactivated. And also odd that it only affected a few of my WordPress sites, not all of them. Weird!

    So it looks like the mystery has been solved! Partially, at least. There must be some odd bug in Safari when Woo Commerce is being used.

    Thanks!

    Me too, after setup cdn and this error show up. I’ve updated all component of wordpress but it not gone. show can somebody explain for me that error. Thank you very much. My site is nhahalong.com

    I’m getting this same error w/ Chrome

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WebSocket connection failed: newest-note-data errors ??’ is closed to new replies.