Support » Fixing WordPress » Website shows up blank

  • Hi,
    I work for a company and I am in charge of running the blog on their WordPress website. On the blog, I create posts about upcoming events in their business. Also, at the bottom of their website, they have a calendar, list of recent blog posts, and list of recent photo posts.

    I began updating their blog around the first week of April. I would make posts and publish them. After publishing, I would preview the work and see how it would look on the website.

    However, last week, I attempted to preview a new blog post and noticed that not only did the post not show up, but nothing would show up except for the page links at the top, the company logo, and an interactive slider. The rest of the page where the blogs, other text, and the bottom of the website is was pure white. It is still showing up like that currently. However, when I go to edit the website as an admin, the blog post list is still there and I am able to update them, however they do not show up on the actual live website.

    Please let me know if there is anything that I can do to help this situation. Thank you.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Support Volunteer

    per this, enable WP_DEBUG and WP_DEBUG_LOG and see what you get.

    https://codex.wordpress.org/WP_DEBUG

    What happens if you create a new post right now with just test content (e.g., This is a test.)? Moreover, if this proves successful, meaning you can successfully make a post right now with test content, what happens if you copy the troublemaker post’s content — make sure to copy from Text and not Visual — and paste it in the new post? Does it still work?

    If not, then might I suggest pasting its contents here for folks to analyze. If the new post with the troublemaker posts content successfully posts then I would simply Trash the troublemaker (and completely delete it), rename your new post whatever the troublemaker’s was, and Save it. Once successful then simply back date it if you wish to whatever the troublemaker’s was and you’ll be golden. 🙂

    Hope this helps!

    Thank you for your follow-up message! I really appreciate the help. However, I might have phrased the problem wrong. Even when I go to the website as I am logged out of my admin account, the entire site shows up blank like I described. When I access the site from a completely different computer or phone, it shows up blank still. No matter what page link I click on (about us, blog, home, contact, etc..) it shows the blank situation.

    I hope this helps. Thank you!

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Support Volunteer

    enable the debug defines as I suggested.

    Please post a url.

    Ah, I see. So, essentially, your whole website is currently “The White Screen of Death” as they like to call it. Have a look here and see if anything helps:

    http://codex.wordpress.org/Common_WordPress_Errors#The_White_Screen_of_Death

    Plus, if possible, @sterndata gave very sage advice.

    Ultimately, the issue will probably end up being one of two things, either a 3rd party incompatibility with your new WordPress update and/or an incompatibility with your server. The former can be tested by you via temporarily disabling ALL your plugins and switching back to the default Twenty Sixteen theme. See these links for help on how to do all this without needing to log in to your website:

    https://codex.wordpress.org/FAQ_Troubleshooting#How_to_deactivate_all_plugins_when_not_able_to_access_the_administrative_menus.3F

    http://www.inmotionhosting.com/support/edu/wordpress/change-theme-in-db
    http://themefuse.com/restoring-wordpress-after-a-crash/

    If it’s the latter, after you have reproduced the issue with all plugins disabled and the Twenty Sixteen theme, then I would contact your host’s tech support and let them know what’s going on with a box stock version of WordPress on their server.

    And, oh yes, as requested by @kmessinger, providing an URL to your site would be very helpful!

    Thank you for the feedback! I will give it a try and will also try to post the URL upon the owner’s request.

    The url to the site is http://oldstumpbrewery.com/! Thank you very much.

    Thanks! Going there now.

    So, your site is up and running but major portions of it are white. I still highly suggest, logging in as an admin, disabling ALL your plugins, and switching back to the default Twenty Sixteen theme just to rule out your issue isn’t a 3rd party one. Which, I bet it is.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Support Volunteer

    You have a jQuery error:

    Uncaught Error: Syntax error, unrecognized expression: > a[href=#]

    Is your theme and are all your plugins up to date? Especially check “Visual Composer” and name sure you’re on version 4.11.2 or better.

    (Also wouldn’t hurt to upgrade from 4.5 to 4.5.1)

    And please do enable debug mode as requested by @sterndata above. Thanks in advance!

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Support Volunteer

    Randy: no need for debug mode at this point. It’s most like a theme or plugin (e.g., Visual Composer) that requires updating. See the JS error.

    Ah, yeah, I saw that after I had posted! 😉

    And to expand on the error message:

    Error: Syntax error, unrecognized expression:  > a[href=#]
    t</fa.error()                    jquery.js:2
    t</fa.tokenize()              jquery.js:2
    fa()                                  jquery.js:2
    .find()                              jquery.js:2
    a.fn.find()                        jquery-migrate.min.js:2
    mainMenu.init()              main.js:130
    <anonymous>                main.js:1976
    n.Callbacks/i()                 jquery.js:2
    n.Callbacks/j.fireWith()   jquery.js:2
    .ready()                            jquery.js:2
    K()                                    jquery.js:2
Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Website shows up blank’ is closed to new replies.