WordPress.org

Forums

Website Redirect Issues (8 posts)

  1. jdsa
    Member
    Posted 1 year ago #

    Please help. I built a wordpress site in a subdirectory folder. I was attempting to make the site live and tried following the online directions of changing the code in the index.php, but now everything is screwed up. I am unable to login to the admin screen. The front page of the website is showing, but the inside pages say that aren't redirecting properly. I'm new to wordpress and am at a complete loss as to what to do.

    The site is http://www.pavementcorporation.com the subdirectory is
    http://www.pavementcorporation.com/wordpress_0

  2. The Grey Parrots
    Member
    Posted 1 year ago #

    Hi,

    Edit your wp-config.php file.

    Define your WP_HOME and WP_SITEURL settings by inserting these lines towars the top:

    define('WP_HOME','http://www.pavementcorporation.com');
    define('WP_SITEURL','http://www.pavementcorporation.com');

    Please be aware you cant change the url via wp-admin dashboard once modified by the config file.

  3. jdsa
    Member
    Posted 1 year ago #

    Thank you for your reply. I think I may have done something wrong. I put in the lines above, but then everything stopped working. The home page was gone and I wasn't able to access the admin page.
    Did I screw something else up?

  4. Mark Senff
    Member
    Posted 1 year ago #

    Please be aware you cant change the url via wp-admin dashboard once modified by the config file.

    ...Which is why it's not the best method to use. :)

    Go to http://pavementcorporation.com/wordpress_0/wp-admin to log in to your admin. Then in Settings -> General and set the WordPress Address to http://pavementcorporation.com/wordpress_0 and the Site Address to http://pavementcorporation.com/

  5. jdsa
    Member
    Posted 1 year ago #

  6. The Grey Parrots
    Member
    Posted 1 year ago #

    In that case you have to update these on wp_options table.

  7. Mark Senff
    Member
    Posted 1 year ago #

    The redirection is fine, that's normal. Can you log in though?

    Try adding this to your wp-config.php file:

    update_option('siteurl','http://www.pavementcorporation.com/wordpress_0');
    update_option('home','http://www.pavementcorporation.com');

    Then try logging in at either http://www.pavementcorporation.com/wp-admin or http://www.pavementcorporation.com/wordpress_0/wp-admin

    If you're successful, remove those two lines again from wp-config.php.

  8. jdsa
    Member
    Posted 1 year ago #

    Thank you both for your help. After much head scratching, turns out the problem seems to lie on on the hosting server. They are rebuilding the database.
    Thanks again!!

Topic Closed

This topic has been closed to new replies.

About this Topic