WordPress.org

Forums

WP Slimstat Analytics
[resolved] Website really slowing down with SlimStat now (13 posts)

  1. Nanowisdoms
    Member
    Posted 1 year ago #

    Slimstat has been working very well so far (installed last Sep), but now it's really slowing my website down. Pages are taking 4-5 seconds to load when they were <1 sec before. If I turn off SlimStat all is fine. I don't have a heavy traffic site and am running Version 3.6.8 of Slimstat. I trimmed my history down to keep only 100 days and that helped marginally. I've turned on the indexes that were supposed to make it "lightening fast". No difference on or off.

    FYI, here are the numbers:

    Engine InnoDB

    wp_slim_stats 7.52 MB
    40,103 records

    wp_slim_outbound 1.5 MB
    6,173 records

    wp_slim_browsers 128 KB
    473 records

    wp_slim_screenres 96 KB
    1,805 records

    wp_slim_content_info 112 KB
    767 records

    https://wordpress.org/plugins/wp-slimstat/

  2. Jason Crouse
    Member
    Plugin Author

    Posted 1 year ago #

    Can you try enabling Javascript mode? I assume you're talking about the public facing website, not the admin, right?

  3. Nanowisdoms
    Member
    Posted 1 year ago #

    Javascript mode was enabled.

    And yes I'm talking about the public website, not admin.

    Enable Tracking Yes
    Monitor Admin Pages Yes
    Enable Spy Mode Yes
    Tracking Mode Javascript

  4. scruffy1
    Member
    Posted 1 year ago #

    can i make a quick suggestion

    we had a similar problem and found it was our firewall blocking an IP associated with a plugin, is that worth checking ?

  5. Jason Crouse
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks, scruffy, that might be worth trying. Also, switching to Server mode might make a difference.

  6. chuyqwerty
    Member
    Posted 1 year ago #

    I have same problem, slowed my site down A LOT. I like the plugin though but wont use unless I figure out why this plugin is slowing my site down.

  7. Jason Crouse
    Member
    Plugin Author

    Posted 1 year ago #

    Are you using server mode or javascript mode?

  8. Nanowisdoms
    Member
    Posted 1 year ago #

    What IP addresses are associated with the plugin?

    As for switching to serverside, that defeats the whole purpose of javascript mode and the advice if using a cache, which I am (Hypercache):

    "Select Javascript if you are using a caching plugin (W3 Total Cache, WP SuperCache, HyperCache, etc). WP SlimStat will behave pretty much like Google Analytics, and visitors whose browser does not support Javascript will be ignored. A nice side effect is that most spammers, search engines and other crawlers will not be tracked."

    But in any event, I tried serverside mode and it made no difference. Just as slow.

  9. Jason Crouse
    Member
    Plugin Author

    Posted 1 year ago #

    Slimstat is not associated to any specific IP address... sorry but I don't understand the question. The switch to server-side tracking was just temporary to try and troubleshoot the issue. We updated our browscap library in version 3.6.9, could you test and see if it makes any difference?

  10. Nanowisdoms
    Member
    Posted 1 year ago #

    Re IP address

    Scruffy wrote: "we had a similar problem and found it was our firewall blocking an IP associated with a plugin, is that worth checking ?"

    You replied: "Slimstat is not associated to any specific IP address"

    Ok, well I'm sure Slimstat connects to some server, according to scruffy and that was being blocked by his firewall and that was causing his problems. Can you tell me what servername/ipaddress this might be so I can check my firewall?

    Re server side/javascript

    Earlier you wrote: "Can you try enabling Javascript mode?"

    I said it's on.

    Later you suggested to scruffy: "Also, switching to Server mode might make a difference."

    I tried that as a test, and was reporting it made no difference.

    Re upgrade. I've upgraded to 3.6.9. It made no difference.

    For now, I'm disabling SlimStat as it's just making the website unusable.

  11. Jason Crouse
    Member
    Plugin Author

    Posted 1 year ago #

    You're right, I apologize for the confusion. Can you go to Settings > Advanced and set UAN to "No"? Does it make any difference that way?

  12. Nanowisdoms
    Member
    Posted 1 year ago #

    Bingo. That was the problem! I turned off UAN and problem gone!

  13. Jason Crouse
    Member
    Plugin Author

    Posted 1 year ago #

    Great, I'm glad I was able to help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.