Support » Plugin: footnotes » Website problems with mobile view

  • Resolved bowport

    (@bowport)


    This was the first time I used the plug-in with this post published today. Looks great on desktop, but on mobile the feature image does not display and the hamburger menu does not work (for any page/post on the site).

    I tried [ref] (( and user defined to no avail.

    Disabling the plugin fixed everything (but of course my 22 references in the article no longer display properly). Site was recently upgraded to WordPress 5.5.1 (but I had not tried the plugin prior to that).

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Lol Zimmerli

    (@lolzim)

    Hello bowport,

    I am not sure that I understand well.

    If I go the the 3rd page of your link with my phone, I can see that:
    https://ibb.co/dQ969SW

    Text with notes and notes.

    What am I doing wrong?

    Best regards

    Plugin Contributor pewgeuges

    (@pewgeuges)

    Hi @bowport,

    Sorry for coming late, and for the trouble you are experiencing.

    For now you have implemented a stable workaround that displays footnotes correctly and prevents mobile visitors from having display issues. I’ve tried out mobile view on a page with a featured image in a local WP sandbox, through the mobile view emulator built into the desktop version of Chrome, but I can’t reproduce the problem.

    The plugin’s CSS does no media queries, so the styles cannot be selectively broken except if it’s due to a failure of the design to be responsive.

    Sorry for not being helpful either.

    Plugin Contributor pewgeuges

    (@pewgeuges)

    @bowport,

    Sorry for being late bringing you a full response. I see that you are using Astra theme. I’ve now tested a website using Footnotes with standard double parentheses (( and )) shortcodes, and Astra theme, by visiting a post with a picture on a smartphone. The mobile menu works, the picture displays, the tooltips show up, the reference container expands and collapses as designed, and moving to anchors works too. Everything is fully functional. WordPress is up-to-date at v5.6.2, Footnotes is current stable v2.5.10.

    While facing the bug that you reported but that we’re unable to reproduce, you have implemented footnotes manually using superscript referrers without links, and a numbered list (without backlinks) for the footnotes.

    Either way, the issue is fixed, and as we haven’t received a response, I’ll mark this topic as resolved. If you wish to try the Footnotes plugin now, please feel free to open a new support topic should you encounter any problems, and we’d be happy to assist.

    Best regards.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Website problems with mobile view’ is closed to new replies.