Support » Plugin: Pods - Custom Content Types and Fields » Website Performance Issues

  • Resolved littleweewebsites

    (@littleweewebsites)


    Whenever I activate the pods plugin my site essentially grinds to a halt, and I get the following errors.

    Warning: Error while sending QUERY packet. PID=18496 in /home/decommissioning/public_html/wp-includes/wp-db.php on line 2007

    When I disable the pods plugin my site is lightening fast again.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • So increased the max_allowed_packet and this resolved the problem for a while. Now the site is super slow again, PODS is definitely doing something to my database. When I try to save a pod I am now getting an AJAX error. When I deactivate PODS my site speed goes back to normal.

    Plugin Author Jim True

    (@jimtrue)

    Some questions:

    1) Is this a new install of Pods or have you always had Pods running on this site and you just started having issues?

    2) Can you provide the System Status report from Pods Admin, Settings?

    3) Please provide the errors you’re getting. We can’t help you without them.

    Plugin Author Scott Kingsley Clark

    (@sc0ttkclark)

    Do you have object caching available on your web host? Have you tried running the Pods Alternative Cache plugin yet?

    Hi Scott,

    Yes i have the cache plugin and it seems to have helped.

    The problem I seem to be having is when I go to save a pod. It takes ages, and then I getting the following error – Error: Invalid AJAX request

    This is not a new install, we have been using pods for about 2 years now.

    Here is the debug information from PODS:

    Debug Information
    WordPress Version: 5.1.1

    PHP Version: 7.1.29

    MySQL Version: 5.6.36

    Server Software: Apache/2.4.29 (Unix) mod_hive/6.27 OpenSSL/1.0.1e-fips mod_fastcgi/2.4.6

    Your User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36

    Session Save Path:

    Session Save Path Exists: No

    Session Save Path Writeable: No

    Session Max Lifetime: 1440

    Opcode Cache:

    Apc: No
    Memcached: No
    OPcache: Yes
    Redis: No
    Object Cache:

    APC: No
    APCu: No
    Memcache: No
    Memcached: Yes
    Redis: No
    WPDB Prefix: wp_

    WP Multisite Mode: No

    WP Memory Limit: 40M

    Current Memory Usage: 211.115M

    Current Memory Usage (real): 213.742M

    Pods Network-Wide Activated: No

    Pods Install Location: /home/decommissioning/public_html/wp-content/plugins/pods/

    Pods Tableless Mode Activated: No

    Pods Light Mode Activated: No

    Currently Active Theme: Boss. Child Theme

    Currently Active Plugins:

    Admin Menu Editor: 1.8.8
    Akismet Anti-Spam: 4.1.1
    bbPress: 2.5.14
    bbP shortcodes: 2.8
    BP Profile Search: 5.0.3
    BP Remove Profile Links: 1.2
    BuddyBoss Media: 3.2.6
    BuddyBoss Products Updater: 1.2.1
    BuddyBoss Wall: 1.3.7
    BuddyPress: 4.3.0
    BuddyPress Docs: 2.1.2
    BuddyPress Follow: 1.2.2
    BuddyPress Global Search: 1.1.9
    BuddyPress Member Types: 1.1.5
    BuddyPress Xprofile Custom Field Types: 1.0.8
    Classic Editor: 1.4
    Contact Form 7: 5.1.1
    Disable REST API: 1.4.3
    Duplicate Post: 3.2.2
    Easy WP SMTP: 1.3.9.1
    GeoDirectory: 2.0.0.57
    GeoDirectory Advanced Search Filters: 2.0.0.10
    GeoDirectory Ajax Duplicate Alert: 2.0.0.2
    GeoDirectory Claim Listings: 2.0.0.8
    GeoDirectory Custom Post Types: 2.0.0.12
    GeoDirectory Location Manager: 2.0.0.16
    GeoDirectory Marker Cluster: 2.0.0.2
    GeoDirectory Pricing Manager: 2.5.0.9
    GeoDirectory Re-Captcha: 2.0.0.2
    GeoDirectory Review Rating Manager: 2.0.0.9
    GeoDirectory Social Importer: 2.0.1.0
    Geoperks: 1.0
    GeoPerks for GeoDirectory: 1.0
    Invite Anyone: 1.4.0
    Invoicing: 1.0.9
    Pods – Custom Content Types and Fields: 2.7.12
    Pods Alternative Cache: 2.0.6
    Precious GeoDirectory BuddyPress Integration: 1.0
    Really Simple SSL: 3.1.5
    reSmush.it Image Optimizer: 0.1.22
    Sassy Social Share: 3.2.22
    Search & Filter: 1.2.11
    Shortcodes For BuddyPress: 1.0.1
    SiteOrigin Widgets Bundle: 1.15.6
    Slider Revolution: 5.4.8
    Ultimate LinkedIn Integration: 1.1.2
    WPBakery Page Builder: 5.5.2
    WP Easy Updates: 1.1.9
    WP JobSearch: 1.2.8

    littleweewebsites

    (@littleweewebsites)

    Any thoughts on this guys?

    I tried another POD and it said ‘cannot complete this request’. Whenever I hit the save pod button it takes typically 30 seconds before returning the message.

    Anything to do with php version?

    Plugin Author Scott Kingsley Clark

    (@sc0ttkclark)

    You should probably increase your memory via: https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    As for the error, can you look at your network tab in your Browser console and look at the response you get back from that AJAX request that’s failing? It might show details as to exactly what error it’s coming back with.

    Plugin Author Jim True

    (@jimtrue)

    We’re closing this ticket, because it seems like you’ve solved it as you’ve not responded in over 5 days.

    If you’re still having issues, please bring it to our Slack Chat at https://support.pods.io/chat/ and we’ll try to point you in the right direction.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.