Support » Plugin: W3 Total Cache » Website outputs in a bunch of strange characters

  • japanworm



    I have had this issue for a long time, unable to solve it. I have tried many things.

    First of all, here’s the problem:
    People have reported that they can’t load my website. All they get is a bunch of random characters:

    I can’t reproduce this problem on my end no matter what device I’m using, so it’s almost impossible for me to fix it. Whenever I try something I can’t even check if it had any effect or not.

    I’ve been using to test, but I don’t get any error messages.
    Yet my readers keep complaining about not being able to load my site!
    I’m losing more and more traffic because of this.

    Often after refreshing or waiting a few minutes, most people seem to be able to load the site properly, though.

    The only time I ever notice that something is wrong is when I try to share one of my posts on Google+. The post’s description then shows up in weird characters.

    I contacted my webhost (LiteSpeed server) and they said they can’t reproduce the issue on their side either. They suggested turning off one plugin after another, but as I can’t see the problem myself, I won’t know if things are fixed or not.

    I also tried to look for any php_flush() snippet in my theme, but couldn’t find any. That was suggested on the FAQ page of the W3 plugin.

    I really hope somebody can help me.
    Otherwise I think I need to disable gzip compression completely.

    Here’s my blog for reference:

    Thanks a lot in advance!

Viewing 8 replies - 1 through 8 (of 8 total)
  • bengirardet


    Hi. I’ve got the exact same issue. Randomly, the output is full of weird characters instead of the normal website.

    If someone can help it would be amazing.



    I had the same problem with LiteSpeed.

    Most likely the server is already G zipping the files.

    You need to turn off G zip compression in W3 Total Cache.




    @kris: Thank you.

    I already turned off Gzip compression as my Litespeed server has enabled it according to my host.
    I just have no idea if the problem was fixed or not as I can’t reproduce it on my side.



    I had the exact problem that your screenshot shows on some sites that I migrated from an apache server and was able to fix it by turning off Gzip in W3 Total cache.

    It happens randomly, right?

    Go to to test your site, Click the advanced settings, set the number of tests to run to 10 and watch the screenshots that it generates.

    W3 total Cache has a total of 4 checkboxes for Gzip, but I believe that the first one unchecks all of them.

    If it’s still happening it could be some bad code in your .htaccess file.

    Make sure you have “verify rewrite rules” checked under the Miscellaneous settings on the general settings screen (Main Screen).

    I would remove all the W3 Total cache code from the .htaccess file and let it reinstall itself.

    Good luck!



    Thank you very much.
    At the moment I cannot recreate the problem and the webpage test doesn’t show any problems either.



    First, You’ve to inspect what is causing the issue by simply going to Minify Settings – General then enable the Minify error notification. By doing the above step you’ll get the error notification that telling you what is the cause of the error dealing with your issue, Thus you could go to the next step to do a required-work given by the error notification to solve the issue .




    I haven’t had any problems recently and also heard no complaints from readers. It might have been figured by turning off the gzip in the plugin as my host is providing it already (gzip enabled).

    I’ll report if there are any problems from now on.

    Same problem here, turning off gzip solved it. Thanks, I’ve been searching for a solution for weeks.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Website outputs in a bunch of strange characters’ is closed to new replies.