Support » Fixing WordPress » Website not loading completely

  • Resolved Ars_b3llicA


    Hey guys,

    I’m a beginner at web development and only do it as a hobby. I’ve been working on a clan website for nearly two weeks now and I could use some advice. Often times when a user first visits my site the page doesn’t completely load. Here is a a pic one of the members sent me:

    What can I do to fix this issue?

    Note: I have just started playing around with jQuery to dynamically load my pages. At the time the screenshot was takin the lazyjaxdavis javascript was not setup. It’s still not completely setup so you’ll see some issues with page loading. This is the first time I’ve worked with jQuery so I still need to do a bit of reading in order to figure it out.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Start by sorting out the markup errors .

    Moderator kmessinger


    The css is not loading.

    Your connection to this server has been blocked in this server’s firewall.
    You need to contact the server owner for further information.

    Your blocked IP address is

    This server’s hostname is

    Note: I have just started playing around with jQuery to dynamically load my pages.

    Do you mean wordpress Pages? They all ready load dynamically.

    @gtantra – I just found the w3 validator so I’ll start working on the errors.

    @kmessinger – I’m trying to setup jQuery so that only the main content box gets reloaded when a user clicks on a link. I started messing with jQuery.LazyJaxDavis last night but after doing some research I’m going to look into using balupton’s history.js

    Is there anything I can do about you being blocked?

    One weird error that I’ve been getting every now and then is that only the following html loads:

    <html><body><script>document.cookie='aaaaaaa=38bc5d30aaaaaaa_38bc5d30; path=/';window.location.href=window.location.href;</script></body></html>

    By hitting refresh a few times the site loads. When I ran the w3 validator a second time the above showed up with the following errors:

    no document type declaration; implying "<!DOCTYPE HTML SYSTEM>"
    document type does not allow element "BODY" here
    required attribute "TYPE" not specified
    end tag for "HTML" which is not finished

    I’m clueless as to what’s going on. Any ideas? In the meantime I’ll continue fixing the markup issues.

    I cleaned up a lot of my themes code and removed almost all of the errors found by the w3 validator. The only error that I didn’t fix was the following:
    “Bad value for attribute action on element form: Must be non-empty.”

    That appears quite a few times in different pages because of the bbpress plugin and all of my changes would be reverted upon an update.

    Other changes:
    Used the image optimizer on my images.
    Moved my login.js to the footer and set it to only load when a user isn’t logged in.

    Despite the above changes the problem is still not fixed. Often times when I first go to the site it doesn’t load. Here is an updated image on what I’m seeing:

    By hitting enter in the address bar the page fully loads the second time around.

    Any more tips?

    Moderator kmessinger


    The image clearly shows the css is not loading.
    When I go directly to the css, I get the firewall blocking message.

    I also sometimes get the one line of html you show above when I look at the source code of the page loaded without the style sheet.

    This is really not a problem with WordPress.

    You could try the basic debug, deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    kmessinger, thanks for following up.

    I submitted a support ticket with my web host last night. They got back to me about an hour ago saying that the IP blocking issue was because of the Cloudflare CDN I setup and they unblocked the IP.

    I actually found the reason I was getting that one line of html was because of a firebug setting. I still have quite a bit more testing to do but everything is loading properly on my end now.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Website not loading completely’ is closed to new replies.