Website loads a different version of css file (12 posts)

  1. dvir0776
    Posted 3 years ago #


    So here's an examplefor this prbolem on my site:

    And the problem is the way my site loads the style.css file.
    It loads it like this:
    <link rel="stylesheet" id="twentytwelve-style-css" href="http://www.betterpurpose.com/wp-content/themes/twentytwelve-child/style.css?ver=3.5" type="text/css" media="all">

    instead of simply /twentytwelve-child/style.css
    it calls for /twentytwelve-child/style.css?ver=3.5
    adding ?ver=3.5

    How do I change that please?


  2. Andrew Nevins
    Forum moderator
    Posted 3 years ago #

    Don't worry, the web server ignores everything at and after the question mark http://stackoverflow.com/questions/438821/what-does-do-in-a-css-link/438828#438828 . You're loading the same CSS file.

  3. dvir0776
    Posted 3 years ago #

    Id like to believe that very much
    expect that in my case they load two different versions
    of the same style.css file.

    have a look



    see? they maybe load the same file, but different versions of it.

    bottom line, how do I make that annoying website simple load


  4. Andrew Nevins
    Forum moderator
    Posted 3 years ago #

  5. dvir0776
    Posted 3 years ago #

    they both load the updated version of the css file,
    which includes
    @import url(../twentytwelve/style.css);.entry-header .comments-link{display:none;}

    but I still can't see how it helps...
    Any further explanation please?

  6. dvir0776
    Posted 3 years ago #


  7. Andrew Nevins
    Forum moderator
    Posted 3 years ago #

    It's only been an hour since someone replied.
    Remember, these are volunteering forums. Nobody is obliged to reply.

    If the issue is considerably important, consider hiring a developer whereby the developer is obliged to help you.

  8. dvir0776
    Posted 3 years ago #

    Ok, thanks, get I should be more patient :)

    Any ideas?

  9. WPyogi
    Forum Moderator
    Posted 3 years ago #

    Have you tried deactivating all your plug-ins and cloudflare? Perhaps it's finding a cached file?

  10. ronangelo
    Posted 3 years ago #

    You only have one style.css in the child-theme folder, right?
    If that's the case then it doesn't really matter.

  11. dvir0776
    Posted 3 years ago #

    OK, so I disabled cloudflare plugin, but still no change.
    It still loads style.css?ver=3.5

    and ronangelo, it does matter because style.css?ver=3.5 and
    style.css aren't the same, and I can't seem to edit
    style.css?ver=3.5 so basiclly I have no way of altering
    the css file of my website, which is pretty crucial.

    Any other ideas? maybe on how I can edit the 3.5 version of the css file?

  12. ronangelo
    Posted 3 years ago #

    It doesn't matter because the style.css will still load regardless. That's the way a child theme works. It appends the latest version of the parent stylesheet.

    The ?ver=3.5 is not a command to the theme itself on which stylesheet to use but instead it is more like a reminder to each user's browser that the latest file version IS 3.5 , so if a user's browser has a cached style.css which is of an older version, the ?ver=3.5 basically instructs the browser not to use the cached version but instead to download a fresh one. You can check my theme on how this works. http://themes.svn.wordpress.org/asteroid/1.0.6/functions.php
    Find "Register & Print the stylesheet"

    Why do you say you can't edit the style.css. Are your modifications not visible? If that's the case your problem might be on using the correct IDs and Classes on your css. Edit your child style.css and see if it works. Try something like this.

    #main {
        background: #000000;

    If the modifications on your child theme works then you have really nothing to worry about.

Topic Closed

This topic has been closed to new replies.

About this Topic