Support » Fixing WordPress » Website issues with "www" & possible plugin conflicts.

  • My site is and I’ve got a long drawn out problem. I’m not even sure exactly what the issue is.

    I run wordpress 3.1.2 with the latest atahualpa 3.6.4.

    Late last night I added two new posts to the site and didn’t touch it for the rest of the evening. Everything was fine with the site until at least 730 this morning. I made no changes for hours prior to 730 and I don’t believe any comments were even left during that timeframe.

    Sometime between 730 and 930 the site suddenly couldn’t resolve the difference between “” and “”. If the WWW was present, the site loaded fine, but if it wasn’t there it returned this error (which generally indicate a space somewhere in the php file).

    Warning: Cannot modify header information – headers already sent by (output started at /home/itsallt/public_html/index.php:98)

    A phpbb forum on the site was similarly affected, but in dealing with the webhost for most of the day they were able to fix the forum – though that fix ended up getting me logged out of wordpress and left me unable to log in at all as the admin screen was now behind the error which changed to this:

    Warning: Cannot modify header information – headers already sent by (output started at /home/itsallt/public_html/wp-content/plugins/dynamic-headers/custom-header.php:97) in /home/itsallt/public_html/wp-includes/pluggable.php on line 897

    The webhost couldn’t do anything more for me. The basic suggestion was to abandon the atahualpa theme. That struck me as odd because I felt it had to at least initially have been a server issue to affect both wordpress and PHPBB. Anyway, they left me kicked out of wordpress and basically high & dry.

    Luckily, I was still logged in to my site via my phone. I disable the dynamic headers plugin and the error switched to being the feedburner plugin. Subsequent errors req’d me to deactivate google sitemaps, nextgen gallery, page links to, polldaddy, stats, pagenavi, table reloaded, wptouch, and yet another related posts plugins.

    After all those were turned off, the site returned to normal whether or not the www was present and I was able to log back into the site.

    So here I am after half a day of issues and tech support. I have my site back, but I had a lot of features wrapped in those plugins and I don’t know if I can turn them back on because I still don’t what went wrong. I’m aware of the spaces issue with that particular header error – and although I never edited them, I did replace with fresh versions but that didn’t do anything. I had to deactivate all the plugins to get anything to load.

    I don’t even really know what my problem is or what I could do to fix it. But any insight would be appreciated.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Here’s a quick update on the plugins. Once I knew I had the ability to deactive them safely, I tried turning on each of the plugins individually to see if I could blame one for my troubles.

    Each one returns this warning and then the header error returns for urls that don’t contain the WWW.

    “The plugin generated 2 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.”

    Wow man u get a loads of comments… Great going… Best of Luck!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Website issues with "www" & possible plugin conflicts.’ is closed to new replies.