Support » Fixing WordPress » Website is redirecting to a different site

  • OK, so here’s the details of what we’ve done in the past few days.

    We have an account setup with Godaddy under their Managed WordPress account. We have WordPress setup and running and everything works fine. Site is http://www.agapechurchwi.com

    However, Godaddy’s Managed WordPress accounts don’t include email accounts and we need some. So, we had Godaddy setup a regular CPanel account for us. It is attached to a different domain name that we have so we could use that as a test to make sure everything looks good before changing it to the actual URL. This domain is http://www.diokolife.com

    I downloaded a copy of all the files from our website as well as did an export of the SQL database. I logged into the CPanel account and uploaded all the files and the database. I also edited the config files with the new database name, user, etc.

    The problem I’m having is that when I go to http://www.diokolife.com I get redirected to http://www.agapechurchwi.com and I can’t figure out why.

    I checked the wp-config file but I don’t have the URLs listed in there at all. I edited the database directly based on instructions on the wordpress website and changed the wp_options table to specify the diokolife.com site.

    I’m completely at a loss as to why it keeps redirecting and what I can do to figure out the problem.

    Thanks for any suggestions.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter kelemvor

    (@kelemvor)

    Can’t see a way to update my post so here’s an update.

    If I go to diokolife.com/wp-admin I am able to log in properly and I stay on the diokolife.com site. If I check Setting | General, the urls on that page are http://www.diokolife.com.

    However, if I go to just diokolife.com, I still get sent to agapechurchwi.com.

    Argh!

    Hi kelemvor !

    You already did great job with transferring your website alone πŸ™‚

    You just missed a lil detail here. You keep being redirected because in the database you imported, your old url is still there. The solution is to :

    – login to your database using PhpMyadmin or from CPanel.
    – under the table “wp_options” ( The table prefix of wp_ may be different if you changed it when installing. ), you will see a field called “option_name”, scroll down and look for “siteurl”. There you will find your old website url which must be replaced with the new one.

    I hope this helps πŸ™‚

    Cheers !

    Thread Starter kelemvor

    (@kelemvor)

    I made those changes but it still redirects. πŸ™

    Hi again !

    Can you please run the following query in your database ?

    UPDATE wp_posts SET post_content = REPLACE(post_content, 'www.agapechurchwi.com', 'www.diokolife.com');

    Let me know if it solves the prob, if not will happily provide more help πŸ™‚

    Cheers

    Thread Starter kelemvor

    (@kelemvor)

    Well crap, that worked. So something in one of the posts was redirecting the entire site over to the other domain?

    Exactly. And it was the post url. Every post is saved in the database with the url associated and the url includes the domain name πŸ™‚

    Good luck with the new domain name kelemvor ! let me know if you need any more help

    Cheers !

    Thread Starter kelemvor

    (@kelemvor)

    OK, well this was fixed. I just checked it again now and it’s redirecting again. I hadn’t done anything to the site since it was fixed a couple days ago. Argh.

    OK. Actually, it doesn’t redirect when I use Chrome or IE, but it does when I use Firefox.

    • This reply was modified 4 years, 5 months ago by kelemvor.
    • This reply was modified 4 years, 5 months ago by kelemvor.

    Hi again kelemvor !

    That’s possibly a cache problem. Can you empty firefox cache and try again ? πŸ™‚

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Website is redirecting to a different site’ is closed to new replies.