Support » Fixing WordPress » Website is now Blank Please Help

  • Resolved methane47


    Good Evening all. I have a big problem.
    So i’ve had a WordPress website up and running for a year now and its been fine. It was setup in the root folder directly in \Public

    Today i decided to see about creating a subfolder WordPress Site where I could test new themes.

    I ran the installer in \Public\Trial

    As soon as that finished I tried to access the site and I noticed I was not able to access my root website any more ( It was just showing a blank white screen.

    I was now only able to access (\Trial) I then went to settings and changed the url for the website back to

    But now is still blank. I’ve tried restoring the Public folder, i’ve tried restoring the Mysql database. But For some reason I am still just seeing a white screen.

    After restoring backups my wp-admin from the root site can see my custom Theme but there is nothing in it. And I cannot see any posts or anything. 🙁

    Please help me. What can I do to get my main site up and running again.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Site URL?

    The true site URL?

    I did some messing around and now the page displays a little bit. I dont know if securities are completely screwed or something

    See if you can login:

    Krishna – I can log in fine, access the Management. It all works, the actual content of the website is not working. And I have no idea why not.

    I can go and select the Theme but the theme has no preview and if you go to the actual website itself, you can see all it currently shows is the blue background and a little formatting.

    Is there anything in the database that needs to change to enable it?
    I set permissions for my website to be 755 should they be different anywhere else?
    Is there some text i need to stick in the htaccess file? or wp-config file? to get this to work?

    Did you check for your posts, media, etc? Don’t you have any installed themes? Can you try these?

    And do you have backups? Because your site shows ZERO content, you may need to restore everything from backup.

    Ok so what i did now is I restored the Public folder from backup and also restored the database from backup.

    Now the site is visible again and most functions work. But the Database is messed up. When i import the database i get the following error:

    #1062 – Duplicate entry ” for key ‘group_system_id’

    The problem here is that the schema has the group system id as UNIQUE. but apparently the data is not unique. Because of this i believe the system does not fully import the database as only the following databases are created:


    It appeares as if there are a few tables missing, But all my database backups give the same error when importing with PHPMYADMIN.

    So current status is that the site is up again, but somethings do not work like adding users (i assume this is because there is no user database) Anyway to edit the DB-GZ before i import it?

    Are you importing to a fresh empty database (no tables) e.g create a database via phpmyadmin then import the backup/tables?

    Yes. The first time i did it, i imported into the existing database. Since then I have deleted the database recreated with the same name and imported again, same error.

    Longshot but – try another (DB) name – sorry i should of explained more – what would do as a process of elimination is delete database, create a new database with a totally different name, then import backup into it. See if the tables are all imported. change the config file to reflect new database name, if it works that is.

    oh i hope you are doing this locally on a test server if not i strongly recommend it

    sorry one more thing that i would like to mention, i have download-monitor as-well and it keeps an access log in the database that can get quite large if not flushed periodically. This plays havoc with my hosts PHPmyAdmin export tool and wont let me export a zip file (it exports the file but with no tables) so i have to export as a raw sql file. Could be related?

    Actually this website is the website for the company i work for. And i just wanted to make some small changes, I managed to break the entire thing… But anyways …

    Thanks for the suggestions but I believe i just resolved it.

    Soooooo Here is what i did. So i realized that my backup db import was probably dropping the current Databases everytime it attempted to import.

    So i took a gamble and extracted the db.gz file and opened it in Notepad. From there i located my problem child table (wp_ps_groups) and manually inserted a value for the Group Id field. I then gzipped it back up. And imported it in phpmyadmin. And now everything is up and running again..


    Sorry, I took a break. But I understand that you could make corrections to your database and you are up and running again. Congratulations!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Website is now Blank Please Help’ is closed to new replies.