Support » Plugin: WordPress Media Library Folders » website images are disappearing

  • Resolved talmor1

    (@talmor1)


    Our website’s media library now has a few hundred items (mainly images)
    It has become difficult to manage, therefore we are interested in arranging the existing images into folders.

    I installed your plugin, however –
    When I move an existing image into a newly created folder, the image disappears from the website. I assume the path is broken.

    It will of course be impossible for me to correct the path in every page of our website.

    For example:
    1. I created a folder called “LOGOs”
    2. I moved our logo’s .png files into this folder.
    3. The logo disappears from the website… It now shows a question mark.
    4. I now need to go to every page the logo appears and fix the path.

    This is of course not possible for us to do for every image.

    Is there any way to make this better?

    Thanks,
    Tal

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author AlanP57

    (@alanp57)

    Image links in standard WordPress post and pages are updated when a file is moved or renamed. It is likely that the links in your pages are stored in a format that prevents the plugin from finding them during the update. What theme or page builder are you using on your site?

    I’m having the same problem. I am using Elementor & Generate Press.

    Plugin Author AlanP57

    (@alanp57)

    Links usually update correctly with Elementor except with background images. I am currently looking into fixing this issue. I’ve also installed GeneratePress and test it with Media Library folders, but I’ve not found an issue with file links not updated when they are moved.

    You can visit the Media Library Folders -> Support page on your site, go to the third tab, System Information, highlight, copy and paste the information about your site and email it to me at alan@maxfoundry.com and I’ll take a look at what is installed.

    Plugin Author AlanP57

    (@alanp57)

    Thank you for the site information. I will be focusing on getting background images updating properly to address this issue.

    Plugin Author AlanP57

    (@alanp57)

    smhcis,

    We have released version 5.0.4 of Media Library Folders that addresses this issue. Links for Elementor background images in posts and pages moved or renamed by Media Library Folders will be updated.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘website images are disappearing’ is closed to new replies.