Support » Plugin: Polylang » Website homepage defaults to secondary language, not to the main language

  • Resolved Alexandra Giula

    (@alaxandra)


    Hello,

    This is quite urgent.
    I have finished setting up two languages:
    – Romanian – the main language, with it’s own frontpage & posts page
    – English – secondary language, with it’s own frontpage & so on.

    All menu items, posts, categories etc. work just fine.

    Except the website defaults as a homepage to English, when it should default to Romanian.

    I currently have selected from settings the following:

    1. URL modifications
    The language is set from content
    2. Remove /language/ in pretty permalinks
    Example: http://www.heymama.ro/en/

    What can I do?

    Thanks in advance for your help,
    Alexandra

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • I found out that after changing the way a language is set, there must be some cookies that linger, and you keep seeing the homepage according to older settings (in my case it was redirecting m=based on my browser language).
    CLEAR YOUR COOKIES & problem solved!

    I wish this was in the FAQs or somewhere, as it took me 5 days of testing & web searches to figure out!

    I am marking as resolved, BY ME. 🙂

    Alexandra

Viewing 1 replies (of 1 total)
  • The topic ‘Website homepage defaults to secondary language, not to the main language’ is closed to new replies.