Support » Fixing WordPress » Website GONE after change of main domain

  • Resolved iii333

    (@streberkatze)


    Hi, I think I may have done something incredibly stupid and am desperate to find out if I can recover my website. My WordPress sites are both hosted by NameCheap. I had one domain that I created first for an old website I created years ago. That website had been in maintenance mode and I hadn’t really been using it. But the domain was still my main domain. Then there is my website that I am still using, another domain, the site also a WordPress site. I asked NameCheap to make that second domain my main domain, so I could get rid of the one I’m no longer using. And now, when I try to open the website I’m actually using, what I see is my old website. When I log into WP admin mode, I get to that website as well. It’s as if my new website has been overwritten by my old one everywhere, and I have no idea if this is it, or how to possibly get it back. Any help greatly appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • @streberkatze
    Don’t worry , check with your hosting provider whether they have the back-up of both the sites.
    If so problem solved , explain them the situation & ask them to re-install the website files you wanted on this new domain & it can be done.
    PS: Always have a latest back-up copy of all your files on your local system too , so that when something happens like this , you can recover the site without depending on a third person.
    Hope it solves your problem.

    iii333

    (@streberkatze)

    Thank you, @phptechie. Will do.

    In the meantime, in my panic, I think I made it even worse. Now I can’t access the WP for either of the sides anymore. Whenever I try to open the /wp-admin/ of my webiste, I get “404 Not Found.” Even if I had to rebuild my website from scratch, at this point, I don’t even know how to get into WordPress. What can I do??

    @streberkatze

    Sorry to hear.
    Can you post the URL to your website ?

    iii333

    (@streberkatze)

    @phptechie

    It’s the one in my profile. (I feel a little hesitant about posting it on here.)

    Since I last posted, the message I see when I try to open the page (or log in to admin) is “There has been a critical error on your website. Please check your site admin email inbox for instructions.” There’s nothing in my inbox though. And I haven’t done anything in the meantime.

    • This reply was modified 9 months, 1 week ago by iii333.
    iii333

    (@streberkatze)

    (Also, I super appreciate the support!)

    @streberkatze

    Sorry for the delayed response.

    Its difficult to solve your problem via this forum , as the rules doesn’t allow to share confidential info like server access , without which it will be difficult to resolve it.

    So as of now you have 2 options , contact the hosting tech support & explain them in detail about the issue & they can certainly help you quickly.

    Else hire a professional programmer & he can help you recover your site if you have the backup.

    Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Website GONE after change of main domain’ is closed to new replies.