Support » Plugin: Nimble Page Builder » Website fonts swap even though pre-load fonts is turned off

  • When my website first loads, it displays a different set of fonts than those that I have selected. Then they are quickly swapped out for the fonts I’ve chosen.

    I had this issue a few months ago and thought I’d figured it out. At the time, I turned off “Preload Google Fonts” in both Customizr (Advanced Options –> Website Performances) and in Nimble Builder (Site Wide Options). Although now, I can’t find Nimble Builder’s “Preload Google Fonts” option. Was it removed or moved elsewhere? Anyway, After I turned these settings off, my selected fonts seemed to load correctly at the time.

    But I am noticing that the fonts still swap when my website first loads.

    Any suggestions?

    Thanks,
    Rob

    ### Begin System Info (Generated 2021-07-26 17:55:35) ###
    ------------ SITE INFO
    Site URL:                 https://test.restartcda.com
    Home URL:                 https://test.restartcda.com
    Multisite:                No
    
    ------------ USER BROWSER
    Platform:                 Windows 
    Browser Name:             Firefox  
    Browser Version:          88.0 
    
    ------------ WORDPRESS CONFIG
    WP Version:               5.8
    Language:                 en_US
    Permalink Structure:      /%postname%/
    Active Theme:             customizr-child 1.0
    Parent Theme:             Customizr 4.4.10
    Show On Front:            page
    Page On Front:            Home (#7)
    Page For Posts:           Unset
    ABSPATH:                  /home/damasc10/public_html/test/
    WP_DEBUG:                 Disabled
    WP Memory Limit:          40MB
    
    ------------ NIMBLE CONFIGURATION
    Version:                  3.1.20
    Upgraded From:            3.1.19
    Started With:             1.10.5
    
    ------------ MU PLUGINS
    Health Check Troubleshooting Mode: 1.7.2
    
    ------------ WP ACTIVE PLUGINS
    All In One WP Security: 4.4.9
    Antispam Bee: 2.9.4
    Childify Me: 1.2.3
    Duplicate Menu: 0.2.2
    Health Check & Troubleshooting: 1.4.5
    Jetpack: 9.9.1
    Limit Login Attempts Reloaded: 2.23.0
    Nimble Page Builder: 3.1.20
    OMGF: 4.4.4
    PHP Compatibility Checker: 1.5.0
    Quiz And Survey Master: 7.2.3
    Rank Math SEO: 1.0.68.1
    Really Simple SSL: 5.0.3
    Stop Spammers: 2021.17
    WP Rollback: 1.7.1
    Yoast Duplicate Post: 4.1.2
    
    ------------ WP INACTIVE PLUGINS
    Photo Gallery: 1.5.80
    reCaptcha by BestWebSoft: 1.63
    Stackable - Gutenberg Blocks: 2.17.3
    Swap Google Fonts Display: 1.0.6
    Videopack (formerly Video Embed & Thumbnail Generator): 4.7.2
    Video Thumbnails: 2.12.3
    W3 Total Cache: 2.1.3 (needs update - 2.1.5)
    WP Super Cache: 1.7.3 (needs update - 1.7.4)
    Yoast SEO: 16.7
    
    ------------ WEBSERVER CONFIG
    PHP Version:              7.4.19
    MySQL Version:            5.5.5
    Webserver Info:           Apache
    Write/Read permissions:   OK
    
    ------------ PHP CONFIG
    Memory Limit:             768M
    Upload Max Size:          512M
    Post Max Size:            512M
    Upload Max Filesize:      512M
    Time Limit:               30
    Max Input Vars:           6200
    Display Errors:           N/A
    PHP Arg Separator:        &
    PHP Allow URL File Open:  1
    
    ### End System Info ###

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Nicolas

    (@nikeo)

    OK thanks for reporting the problem. No suggestions for now, I need to explore this issue to understand the problem.

    Thread Starter rob2550

    (@rob2550)

    Update: Upon further investigation, this issue does not seem to be caused by Nimble Builder. When I disable Nimble Builder (and all other plugins) and leave Customizr theme active, the fonts still swap. So I think it has to do with the Customizr theme.

    I think issue is related to old fonts which are somehow being saved into memory somewhere. When site first loads, it switches between multiple fonts and the menu shifts back and forth too.

    Thread Starter rob2550

    (@rob2550)

    Update, part 2:

    I have tested this more and when the site first loads, it appears to choose “Impact and Palatino” from the Customizr font picker before it switches to the font I have actually chosen, which is Roboto.

    If I choose from one of the 4 sets of “Web Safe font pairs”, it seems to work fine and not swap fonts. It also seems to work fine if I choose Helvetica, Palatino Linotype, Verdana, and Times New Roman.

    It does not like the Google Font pairs and a lot of other single fonts. It has swap issues with those.

    Once I reactivate Nimble Builder, I see the same thing happening with the Nimble Builder sections. I have to choose a font like “Verdana, Geneva, sans-serif” for it not to swap. Other Nimble Builder sections that have a font like “Monserrat 300” also have the swap issue, and swap from something else first.

    It seems like the only thing Customizr and Nimble Builder will tolerate are basic boring system fonts.

    I tried disabling all plugins, installed a fresh copy of Customizr and deactivated child theme, and this issue still occurred.

    Lastly, I created a brand new WordPress install with only the Customizr theme installed (no plugins), and the font issue still occurs.

    Here is the freshly installed site: http://test3.restartcda.com/

    So I’m quite sure that this is a Customizr bug.

    # SITE_URL:                 https://test3.restartcda.com
    # HOME_URL:                 https://test3.restartcda.com
    # IS MULTISITE :            No
    
    # ACTIVE THEME :            Customizr 4.4.10
    # WP VERSION :              5.8
    # PERMALINK STRUCTURE :     /%year%/%monthnum%/%day%/%postname%/
    
    # ACTIVE PLUGINS :
    
    PHP Version:              7.2.34
    MySQL Version:            5.5.5-10.2.39-MariaDB-log
    Web Server Info:          Apache
    
    WordPress Memory Limit:   40MB
    PHP Memory Limit:         768M
    PHP Upload Max Size:      512M
    PHP Post Max Size:        512M
    PHP Upload Max Filesize:  512M
    PHP Time Limit:           30
    PHP Max Input Vars:       6200
    PHP Arg Separator:        &
    PHP Allow URL File Open:  Yes
    WP_DEBUG:                 Disabled
    
    Show On Front:            posts
    Page On Front:             (#0)
    Page For Posts:            (#0)
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.