Support » Plugin: WooCommerce » Website down after update to 4.5.2.

  • Resolved dyin

    (@dyin)


    Hello Woocommerce,

    Yesterday evening I did a minor update from 4.5.1 to 4.5.2 (so I thought it would be safe).

    However after the update I got error 500 on all website pages. A rollback was not succesful and I had to reupload a backup ( at 1am 🙁 ). I am running the latest WordPress version.

    Warning: Use of undefined constant WOOCOMMERCE_VERSION - assumed 'WOOCOMMERCE_VERSION' (this will throw an Error in a future version of PHP) in /data/sites/web/mysitebe/www/wp-content/plugins/woocommerce-zapier/woocommerce-zapier.php on line 199
    
    Fatal error: Uncaught Error: Call to undefined function WC() in /data/sites/web/mysitebe/www/wp-content/plugins/woocommerce-checkout-field-editor-pro/includes/class-thwcfe.php:78 Stack trace: #0 /data/sites/web/mysitebe/www/wp-content/plugins/woocommerce-checkout-field-editor-pro/includes/class-thwcfe.php(72): THWCFE->define_constants() #1 /data/sites/web/mysitebe/www/wp-includes/class-wp-hook.php(287): THWCFE->init('') #2 /data/sites/web/mysitebe/www/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array) #3 /data/sites/web/mysitebe/www/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #4 /data/sites/web/mysitebe/www/wp-settings.php(546): do_action('init') #5 /data/sites/web/mysitebe/www/wp-config.php(90): require_once('/data/sites/web...') #6 /data/sites/web/mysitebe/www/wp-load.php(37): require_once('/data/sites/web...') #7 /data/sites/web/mysitebe/www/wp-blog-header.php(13): require_once('/data/sites/web...') #8 /data/sites/web/mysitebe/www/index.php(17): re in /data/sites/web/mysitebe/www/wp-content/plugins/woocommerce-checkout-field-editor-pro/includes/class-thwcfe.php on line 78
    Er heeft zich een kritische fout voorgedaan op je site.
    
    Meer informatie over probleemoplossing in WordPress.
    

    It seems to be a conflict with the checkout-field-editor plugin.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support RK

    (@riaanknoetze)

    Hi there,

    Looking at the path of the error you share, it seems that it’s indeed caused by one of your 3rd party plugin: plugins/woocommerce-checkout-field-editor-pro

    For more help on that, please get in touch with the developers of that plugin to take a closer look.

    Thread Starter dyin

    (@dyin)

    @riaanknoetze Yup I send them a message. I posted it here in case there is a conflict somewhere in the code that is avoidable from your end. It did happen when I did a minor update.

    Plugin Support RK

    (@riaanknoetze)

    Thanks! It’s quite likely to be a conflict although this would be something to fix from their side as (1) we don’t have any direct access to their premium plugin, and (2) WooCommerce doesn’t expressly provide support for *specific* 3rd party plugins. If, however, this is something that needs to be addressed in the core WooCommerce plugin that’ll benefit *all* users, then their devs would need to submit code change proposals at https://github.com/woocommerce/woocommerce

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.