Support » Plugin: Cloudflare » Website broken with 3.0

  • Just updated to 3.0 and our website broke. The Cloudflare error about the website being down is displayed, but the website actually works. When I browsed to the direct address the following error was displayed:

    Warning: array_walk() expects parameter 1 to be array, null given in /srv/users/serverpilot/apps/wordpress/public/wp-content/plugins/cloudflare/src/Hooks/HTTP2ServerPush.php on line 72

    Warning: array_walk() expects parameter 1 to be array, null given in /srv/users/serverpilot/apps/wordpress/public/wp-content/plugins/cloudflare/src/Hooks/HTTP2ServerPush.php on line 72

    Disabled the plugin and the website worked again. Please advice.

Viewing 15 replies - 1 through 15 (of 29 total)
  • have the same problem

    Hi,

    Same error here:

    “PHP message: PHP Warning: array_walk() expects parameter 1 to be array, null given in /var/www/secret.url/htdocs/wp-content/plugins/cloudflare/src/Hooks/HTTP2ServerPush.php on line 72” while reading response header from upstream, client: 141.101.99.57, server: revision.co.zw, request: “GET / HTTP/1.1

    • This reply was modified 4 years, 9 months ago by garikaib.

    I’m seeing the same error.

    you can fix it temporary with adding @ before array_walk

    Hi,

    Can you please give me some information about your server:

    Additional errors in your php error log
    What version of WordPress are you running?
    What version of PHP are you reading?

    • This reply was modified 4 years, 9 months ago by thellimist.
    • This reply was modified 4 years, 9 months ago by thellimist.
    • This reply was modified 4 years, 9 months ago by thellimist.

    No, only those errors (after update to v.3)
    Wordpress 3.6.1
    PHP 7.0

    Oops, 4.6.1

    Does your server support HTTP/2?

    Yes

    I also can’t access the backend of my website anymore since I updated to v3.0.
    Last month, I couldn’t access my website for two days because of a CloudFlare error.

    Ray ID: 2e33e068e41b40e2
    WordPress: 4.6.1
    PHP 7.0
    HTTP/2 supported

    Please solve this problem asap as I need to work. Thanks.

    Hi Kenika,

    I also can’t access the backend of my website

    – Do you mean you can’t access to wp-admin or you can not ssh to your server?
    – Can you post your error logs?
    – If the error is visible in your website could you post them too.

    Thank you

    The Cloudflare error about the website being down is displayed

    What is the error code you are getting? I’ve been able to reproduce the following warning message and it doesn’t bring the website down.

    Warning: array_walk() expects parameter 1 to be array, null given in .../wp-content/plugins/cloudflare/src/Hooks/HTTP2ServerPush.php on line 72

    I just deactivated the CloudFlare plugin. Now I can access all admin pages again. But activating it again (which I’d like to do) brings me to the 520 error page. (That’s where I got the ray ID from.)

    I’m experiencing the same issue on all my sites (single & mu).
    /wp-admin is accessible, however, if I go to edit a post I get the cloud can’t connect screen. This is the case for many of the extension settings in the back end.

    Same.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Website broken with 3.0’ is closed to new replies.