Support » Plugin: Yoast SEO » website backend very very slow after update 10.1.1

  • Resolved HeleneL

    (@helenel)


    Hello,

    Right after the latest update (10.1.1), we started experimenting an extremely slow backend/admin. It was impossible to update other plugins, posts were running autosaving all the time without ever managing to finish the process etc.
    and the CPU usage went up to the roof.

    I had to deactivate Yoast… and everything went back to normal. Thus I assume there is a glitch somewhere, but no idea where…
    I wanted to try to find and reinstall a previous version that worked fine, unfortunately I cannot find any 🙁
    Hopefully, you can help and find what went wrong BTW on latest wordpress, i.e. 5.1.1.)

    Thanks and great plugin BTW!
    All the best
    Helene

    • This topic was modified 3 years, 1 month ago by HeleneL.

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • I had the same issue. I have a large site, installed the update, and it 504’d everything for quite a while. There were some other complications, but I had to end up manually removing the plugin.

    New Relic reported a slow query by the plugin:

    UPDATE wp_options SET option_value = ?, autoload = ? WHERE option_name = ?

    Here’s the callstack:

    …d at /srv/bindings/a0c8104cb1604e4b8d9fbfd253938461/code/wp-includes/
    wp-db.php (1924)
    …d at /srv/bindings/a0c8104cb1604e4b8d9fbfd253938461/code/wp-includes/
    wp-db.php (1813)
    …d at /srv/bindings/a0c8104cb1604e4b8d9fbfd253938461/code/wp-includes/
    wp-db.php (2166)
    … at /srv/bindings/a0c8104cb1604e4b8d9fbfd253938461/code/wp-includes/
    option.php (369)
    …d253938461/code/wp-content/plugins/wordpress-seo/inc/
    class-upgrade-history.php (112)
    …d253938461/code/wp-content/plugins/wordpress-seo/inc/
    class-upgrade-history.php (71)
    …4b8d9fbfd253938461/code/wp-content/plugins/wordpress-seo/inc/
    class-upgrade.php (156)
    …4b8d9fbfd253938461/code/wp-content/plugins/wordpress-seo/inc/
    class-upgrade.php (22)
    …b1604e4b8d9fbfd253938461/code/wp-content/plugins/wordpress-seo/
    wp-seo-main.php (306)
    …v/bindings/a0c8104cb1604e4b8d9fbfd253938461/code/wp-includes/
    class-wp-hook.php (286)
    …v/bindings/a0c8104cb1604e4b8d9fbfd253938461/code/wp-includes/
    class-wp-hook.php (310)
    … at /srv/bindings/a0c8104cb1604e4b8d9fbfd253938461/code/wp-includes/
    plugin.php (453)
    … called at /srv/bindings/a0c8104cb1604e4b8d9fbfd253938461/code/
    wp-settings.php (327)
    …ce called at /srv/bindings/a0c8104cb1604e4b8d9fbfd253938461/code/
    wp-config.php (203)
    …once called at /srv/bindings/a0c8104cb1604e4b8d9fbfd253938461/code/
    wp-load.php (37)
    …lled at /srv/bindings/a0c8104cb1604e4b8d9fbfd253938461/code/
    wp-blog-header.php (13)
    …equire called at /srv/bindings/a0c8104cb1604e4b8d9fbfd253938461/code/
    index.php (17)
    • This reply was modified 3 years, 1 month ago by johnReeve.
    Thread Starter HeleneL

    (@helenel)

    Hello again,

    First, I am glad not to have been the only one facing the problem. Thanks to John for sharing the logs (I would do the same if I knew how to do it).

    Unfortunately, after having updated to 10.1.2, the problem persisted. For example, it was impossible to update any post… each update led to “update failed”. The charge on the CPU was nonetheless less heavy.

    As soon as I deactivated Yoast, I could again update easily posts.
    Sorry about the bad news.. 🙁

    Looking forward to the next update…
    Thanks for your efforts!
    Helene

    I have the same problem.

    I didn’t noticed it with 10.1.1 but since this morning with 10.1.2, I’m fighting very high load that is automatically reduced to normal when I remove Yoast SEO.

    There seems to be a ton of update options or maybe something that is called on every page load.

    Reporting the same issue. I’ve disabled Yoast until another update comes out.

    Same issue over here, allready emailed Yoast with the errors, but no reaction yet. Keep you posted

    Plugin Support benvaassen

    (@benvaassen)

    Hi everyone,

    I’m sorry this is happening for every one of you.

    We’re currently looking into this trying to find the cause. Does the issue also happen when Yoast SEO is the only plugin that’s active? Including the number of pages/posts can also be helpful for us.

    Also, if you have any additional information, please let us know via screenshots or with steps on how we can reproduce this behavior! Thanks!

    Hi,

    I can’t really help with the disabling of plugin on my live website, but here’s a screenshot I took of the mysql process queue yesterday when the load got very high very quickly.

    Maybe that can help….

    https://prnt.sc/n7gtrm

    Plugin Support benvaassen

    (@benvaassen)

    Hi everyone,

    Thanks for your patience. We’ve just released a patch that should fix this. Can you update to Yoast SEO (Premium) version 10.1.3 and let us know if it’s working for you?

    10.1.3 is working for my sites.

    But still it’s updating wp_otpions with 15meg record with option name = wpseo_upgrade_history!!!

    I updated to 10.1.3 and everything does seem fine.

    Thanks.

    I have been having this same issue for awhile. Just saw this when looking for help with another issue on the back end.

    I disabled Yoast SEO Premium which is Version 10.1.3. And the back end speed is back to normal for me. The patch didn’t work for me I guess.

    Didn’t fix my other issue either. On to that now.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi @dmiyares & @trishak

    v10.1.3 was expected to fix a site speed issue some users had reported. However, if you are still experiencing site speed issues even after updating to 10.1.3, we ask that you please make a new topic.

    That way we can help you with this new issue and provide a more focused reply.

    • This reply was modified 3 years, 1 month ago by Pcosta88.
    • This reply was modified 3 years, 1 month ago by Pcosta88.
    Thread Starter HeleneL

    (@helenel)

    Everything works perfectly well now! I was quite sure I had reported about problems being solved earlier, but obviously not.

    Thanks again for all your efforts and very quickly too,
    Helene

    Plugin Support devnihil

    (@devnihil)

    @helenel Thanks for confirming that the update corrected your issue. We are going ahead and marking this issue as resolved. If you require any further assistance please create a new issue.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘website backend very very slow after update 10.1.1’ is closed to new replies.