Support » Plugin: Yoast SEO » webpage schema on articles

  • Resolved BlogAid

    (@blogaid)


    In the Google Structured Data Testing tool, I see the top schema output on my blog posts as WebPage instead of Article. Using the new Google Rich Results Tester, I don’t see Article at the top. I also don’t see any errors in either of them, or issues loading the page.

    What could be the cause of not outputting the proper schema markup for articles?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Thread Starter BlogAid

    (@blogaid)

    I do have the Knowledge Graph section filled out. Have had the same info there ever since it was available. It is set to Organization with my Organization name and logo file link. I tested the logo file link to ensure it was still good. And I saved the changes, just to refresh it.

    Plugin Support Suwash Kunwar

    (@suascat_wp)

    Hi @blogaid

    The Yoast plugin uses the Article schema on your posts. Can you please go to SEO > Search Appearance > Content Type and make sure the default Article schema is selected for posts?

    Thread Starter BlogAid

    (@blogaid)

    In Content Type, in the Posts section, the Schema settings are:
    Default Page type – Web page (default)
    Default Article type – Article (default)

    In the Pages section, the Schema settings are:
    Default Page type – Web page (default)

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Thanks for your confirmation. It looks like you have all the settings technically correct but the individual posts are still not showing the Article schema type.

    We also see that you have defined the Organization settings from the Yoast SEO but Organization schema markups are also not appearing on the individual blog posts which is odd.

    In this case, we recommend you please perform a conflict check to see whether there’s anything interfering with the Yoast SEO generated schema markup on your site. You can find the relevant guide here https://yoast.com/help/how-to-check-for-plugin-conflicts/.

    Thread Starter BlogAid

    (@blogaid)

    I manually disabled all plugins except for Yoast and ran checks on several posts. Still no Articles schema on any of them using the Rich Results Tester, and still coming up as Webpage on the SDTT.

    I cannot switch my theme to the default on my live site, as it would be too insanely disruptive, so guessing I will need to clone and do more disruptive testing there, unless you have some other ideas for things to check

    Plugin Support Michael Tina

    (@mikes41720)

    Hi,

    If you were to edit that specific post and go to the Yoast SEO meta box and go to the Schema tab, could you check if the Article type for that post is also set to the default for posts (Article)?

    You might also want to check our documentation here for the required properties for the Article schema to output. If there are any missing fields, it would then not output the Article schema — https://developer.yoast.com/features/schema/pieces/article/

    Thread Starter BlogAid

    (@blogaid)

    I edited that post and went to the Schema tab and the settings are
    Page type – Default for Posts (Web Page)
    Article type – Default for Posts (Article)

    I checked several other posts as well and they are all the same.

    I looked at the requirements and tested in the Structured Data Testing Tool.

    Since Yoast is supposed to be supplying all of the article markup, and this post is being seen in the Structured Data Testing Tool as a Webpage, how in the heck could it ever qualify as an article, as it’s not outputting any of those specific article things? They are missing from the Yoast output. It has all of the WebPage schema, just not the Article schema. And that’s the problem we are troubleshooting.

    I’m really confused by the suggestion to check those requirements. What would we be looking for?

    Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi @blogaid,

    To help us troubleshoot, please answer the questions below:

    1. If you go to SEO > Search Appearance, do you have a person or organization selected under ‘Knowledge Graph & Schema.org’? If not, please add all the required information including an image.

    2. Have you assigned a featured image for the page? If yes, can you send us a screenshot of this setting on the post edit screen?

    3. If you change the schema type to something other than article, does anything different appear?

    You may need to clear any cache from any plugins or from your server if you make any changes before you test the schema data again.

    Thread Starter BlogAid

    (@blogaid)

    I have cloned the site to a new cPanel so I can do disruptive testing.

    This way the site is not on Cloudflare.

    All plugins have been deactivated except for Yoast SEO. That includes all of the caching plugins too.

    The theme was changed to TwentyTwenty

    I tested with Discourage Search Bots on and then turned that off and tested again, so this clone does not get indexed.

    This is one of the posts I’m using to test https://ba.myblogaid.net/is-blogging-for-dollars-worth-it/

    I ran the post through the Structured Data Testing Tool.
    It now shows href too, but it still shows the post as WebPage, not Article.

    The Rich Results Tester is the same. It has no loading issues and only detects SiteLinks Search Box in the rich results. It still does not show Article or WebPage.

    To answer your questions:

    1. SEO > Search Appearance is set to Organization and has all info filled in. If you’ll look earlier in this ticket, you can see that was already checked and verified in the HTML, but is not being output in the schema.

    2. All posts have a featured image assigned. I don’t see how to share a screenshot or upload an image in this forum. But I did actually check to verify that the featured image was assigned on the post above, and all other posts I have tested.

    3. On the post, in the Schema tab, I set the Article Type to News Article and ran the tests again – no difference in output.

    The site is still in the above condition for your further testing/checks

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    In our testing if you set it organization or person in the SEO-Search Appearance section and have a logo set (see image: https://ibb.co/sbvWk4R) and have the defaults of the page configured (see image: https://ibb.co/1Rcv9Lc) Yoast would output article schema into the source of the page (see image: https://ibb.co/qxPh2S4). The data testing tool would show it correctly. See image: https://ibb.co/W5CpHW7.

    We are not sure why the article schema is failing to output correctly. We suggest the following actions:

    1. Does clearing your caching from your theme, plugin, server, CDN like CloudFlare or browser resolve the issue? If you are not sure how to clear caching from theme/plugin please speak to those authors. If you want to clear cache from the server, please speak to your host provider. To clear the cache from a browser use this guide: https://yoast.com/help/how-to-clear-my-browsers-cache/

    2. If you use the Yoast Helper Tool does the issue resolve? We ask as we store data in tables in the database and this will reset them and help to rule out incorrect data being pulled from the database. Please try the steps below:
    – i. Install & activate the Yoast Test Helper plugin: https://wordpress.org/plugins/yoast-test-helper/
    – ii. Go to Tools -> Yoast Test
    – iii. Locate the Yoast SEO section and select the “Reset indexables tables & migrations” button
    – iv. Click the “SEO Data” button in the SEO->Tools section.

    3. Are all your non-Yoast plugins and themes also updated?

    4. Can you confirm you are using the most recent Yoast SEO, v15.3? If you update, does the issue resolve?

    If all are updated and clearing the cache and resetting the database fails to resolve the issue then it is likely this issue here: https://github.com/Yoast/wordpress-seo/issues/14879, which reports on several cases where the article schema fails to be generated.

    We recommend commenting on the issue with as much information as you can provide about it and add a link back to this topic. You may need an account in order to comment.

    If you are not sure what kind of information to add this guide can help: https://yoast.com/help/how-to-write-a-good-bug-report/.

    Thread Starter BlogAid

    (@blogaid)

    If you read my last reply, you’ll see that I cloned the site, turned off all plugins except Yoast, and switched to the TwentyTwenty theme. This clone is also not on Cloudflare, so there is no caching.

    If you look through the rest of the ticket, you’ll see that all of other checks had already been done.

    And yes, confirmed I’m on the 15.3 version.

    I installed the Yoast Test Helper and did the 2 steps you advised. It returned the SEO data optimization complete message after the 2nd step.

    I looked at the GitHub post. I am not a developer and have no way to go into the code at that level.

    But, with every other plugin off, and on the TwentyTwenty theme, would we not have eliminated those other issues?

    And just to be sure there is nothing in the post itself that could be causing this, I created a new post and had the same test results.

    The new post has a title and a paragraph, and all schema settings were checked to be at the same defaults I have already confirmed above.

    The new post is here https://ba.myblogaid.net/test-post/

    I think we are at the end of eliminating other causes. What else could be checked?

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    We apologize. We are not familiar with the clone site but we do know some sites still retain server caching (even on staging or clone sites) and we can see you are using WP Fastest cache and we just wanted to be sure all the caching has been fully removed.

    We say this as things can get caught in the cache (such as individual schema tags).

    In regards to that GitHub post, we do not mean to imply that you need to develop the code at a specific level. Rather we mean to say that we have come across this kind of issue before.

    As we have ruled out common issues and can confirm it still happens on a clean site, it seems to be a bug with the set-up. We can only suggest commenting on that report here: https://github.com/Yoast/wordpress-seo/issues/14879.

    Unfortunately, no workarounds exist for the issue.

    Thread Starter BlogAid

    (@blogaid)

    I ran a header check on the newest post I created and don’t see any caching in it at all.
    It’s this post https://ba.myblogaid.net/test-post/
    Results are below.

    I also contacted my host, as I’m on a Litespeed server, but not using LSCache, and they confirmed there is no server-side caching on anywhere, including the clone site. I also verified that it is Disabled in the cPanel.

    So, how is WP Fastest Cache and server-side cache affecting it, and what link are you checking on? Hopefully it is this newest one on the clone.

    HTTP/1.1 200 OK
    Connection: close
    X-Powered-By: PHP/7.3.24
    Content-Type: text/html;charset=UTF-8
    Link: <https://ba.myblogaid.net/wp-json/&gt;;rel="https://api.w.org/&quot;
    Link:
    <https://ba.myblogaid.net/wp-json/wp/v2/posts/18813&gt;;rel="alternate";type="application/json"
    Link: <https://ba.myblogaid.net/?p=18813&gt;;rel=shortlink
    Transfer-Encoding: chunked
    Date: Mon, 30 Nov 2020 16:26:23 GMT
    Server: LiteSpeed
    X-Xss-Protection: 1;mode=block
    Referrer-Policy: no-referrer-when-downgrade
    X-FRAME-OPTIONS: SAMEORIGIN
    Content-Security-Policy: block-all-mixed-content
    Alt-Svc: quic=":443";ma=2592000;v="43,46", h3-Q043=":443";ma=2592000,
    h3-Q046=":443";ma=2592000, h3-Q050=":443";ma=2592000, h3-25=":443";ma=2592000,
    h3-27=":443";ma=2592000

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    We are not familiar with all the caching solutions you have on your site. We only know that some sites set-up caching in a variety of ways so we wanted to be sure to rule out all the possible ways caching is set-up.

    We say this as one of our initial hunches was that caching was blocking the schema from appearing correctly. As you did a conflict check (and turned off the WP Fastest Plugin which would also disable the caching from it) our hunch is incorrect.

    As a result, we think it is that bug that has been reported at that GitHub link. We can only say to comment on the report. This will give you updates via email as to when it has a resolution.

    In regards to what link we looked at, we looked at this link here: https://blogaid.net/tips-tuesday-holiday-sales-video-seo-research-astra-schema-markup-amazon-s3-email/

    Thread Starter BlogAid

    (@blogaid)

    I appreciate the help – but it’s not helpful if folks are replying without following the thread and looking at the links and info that have the latest changes.

    It’s like starting from square 1 constantly instead of methodically troubleshooting the issue.

    And waiting for a bug to get fixed that is already 7 months old is not acceptable. I’m loosing SEO ground every minute of every day.

    I purchased the SEO premium plugin just so I can hopefully get more methodical help, as I believe we have reached the end of what we can do here, with ruling things out as much as possible.

    As stated, I appreciate the help. And hopefully folks replying or seeing this will read the thread and perhaps add something that has not already been tried and eliminated as a cause.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘webpage schema on articles’ is closed to new replies.