Support » Plugins » Webp SG Optimize plugin problems

  • I have 3 websites with Siteground. Love Siteground but the SG Optimized plugin is no good. I own 3 website. My websites were very fast until i enabled WEBP images. This made my websites very very slow because it generates new images on your server. I had to figure it out on my own as they don’t warn you of this. Once i unticked (few hours) the webp in site ground my website came back slowly but surely, in a few hours, my website was very fast. I know Google wants WEBP but not all browsers support it yet, not to mention, WE DONT WANT A SLOW WEBSITE. I love Siteground but not the Optimizer plugin…

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hello @jolizzie589,

    The .webp image optimization may take some time based on the number of images that would need to be converted.

    During that period you may sense a slower performance of the application due to the backend process that is executed in batches of 200 at a time. Once the optimization is completed, the website speed should improve.

    Best regards,
    Georgi Ganchev

    ldallara

    (@ldallara)

    It worked for a week and then stopped working. Now it does not see the .webp files.
    It created all the files in the upload dir.
    Not what to do maybe start over and un-install and re-install?
    The cache doesn’t work either.
    I’m on Siteground

    Hello @ldallara,

    Please make sure that your Nginx Direct Delivery(Site Tools > Speed > Caching) option is currently enabled and your WP Cron is working as expected.

    In case, the issue persists, please start your own topic and we will be glad to assist you further:

    https://wordpress.org/support/plugin/sg-cachepress/#new-post

    Regards,
    Vladimir

    ldallara

    (@ldallara)

    Hi Vladimir;

    WP Cron is not working as expected, I get a blank screen, when I run https://louisdallaraphotography.com/wp-cron.php

    The cron file is there.

    Hello @ldallara

    I checked the site, and the cron is working correctly. Direct access to it is normal to show a blank page.

    The site was slow on my end when I checked it, and I was able to resolve it by deactivating the Memcache service for the site.

    Thread Starter jolizzie589

    (@jolizzie589)

    Hello Georgi,

    So, i had the plugin for months and i dont think it takes months for the webp to create. With that being said, Creating the webp makes several copies of every single image size, creating a larger database. so, not only do i have several image sizes for my images, enabling webp creates (5 different image sizes) 5X more exhaustion on my server. I don’t feel having webp images is an asset to my website as it slowed my website down considerable due to webp creating 5X more images (even though not all browsers do not support webp images) In my research, Webp images dont save that much. I had an image that was 150KB but the Webp version was only 140KB. Not worth my website being slow due to multiple versions. I think maybe it will be good to have Webp images on a BLOG with very little images, but with a retail store with hundreds or thousands of images, It can cause a very catastrophic situation…. I am still deleting thousands of WEbp images in my file manager. Such a pain as it creates higher INodes if you dont delete images not used… I love siteground… But the Sightground Optimize plugin is not good. Another issue i had with this plugin is that the catch didnt work. I would test my page to see if my page was cached, and it always said “The page is not cached”. All 3 of my websites said this so i know it wasnt just isolated to the one.I read where they disabled Memcached for their caching to work on their website, But isnt the Memcached supposed to be powerful? I Disabled all plugins to see to see if there was a conflict with the caching, It turned out that the Woocommerce plugin conflicted with the Siteground Optimized plugin. I contacted both Woocommerce and Siteground Optimize and they blamed each other leaving me going back and forth. I finally made a decision to delete the Siteground Optimization plugin, and activate the autotomize plugin, and i’m happy. The siteground plugin needs a lot of work…. I dont have time to be a guinea pig and see if it works. I have a business to run and i expect a plugin to work the way it says it does.

    Georgi Ganchev

    (@georgiganchev)

    Hello @jolizzie589

    We appreciate your feedback!

    Please allow me to explain that converting to .webp cannot create different resolutions of your images. The functionality only converts existing images and creates their .webp copies. If a browser can resolve .webp images those would load immediately for the visitor.

    Additional information on the .webp benefits can be found here https://developers.google.com/speed/webp

    The image resize is a default WordPress functionality. WordPress automatically resizes images to help you save bandwidth. In addition to the image sizes generated by WordPress, your theme may also create copies or additional image sizes. By using WebP Images our plugin converts all existing image sizes to the chosen format.

    As for the caching issues, those can be looked at further if you open a ticket in our Helpdesk. Dynamic caching is regulated over caching headers and cookies. There would be a particular reason if a certain webpage of your website is not being cached. Memcached is a different caching mechanism. It is proven useful in storing frequently executed database queries and reusign them for better performance.

    Best regards,
    Georgi Ganchev

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    Everyone: This is not a review; it’s a support topic. I’m going to try to move it from reviews into the plugin’s support area. If I break the forums, apologies in advance. 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.