Support » Plugin: ShortPixel Image Optimizer » WebP on Safari NOT WORKING

  • Hello ShortPixel.

    Im using Premium Version of your plugin. Ive used your WebP feature. But then the site is now not displaying images properly on Safari.

    I have then disabled the WebP feature, and checked the htaccess if the codes were already removed. Only the comment remains. Ive tried so many fixes, and searched the Google for hours for solutions, all of them not working.

    Now on Safari, the error is this – “Resource interpreted as Image but transferred with MIME type image/webp.” But the next 3 refresh after emptying cache, the images will then appear. Its not caching issue because ive disabled other plugins including cache plugin, and made sure that the line of codes were removed on htaccess.

    Can you please help?? Thank you.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Gerard Blanco

    (@sixaxis)

    Hi @neovlademarvel,

    Can you please elaborate on the issue? What do you mean by “the site is now not displaying images properly on Safari”? Can you send us some screenshots, please?

    In any case, if the issue is that WebP images are not displayed on Safari, that’s normal: Safari doesn’t support WebP.

    Best,

    @sixaxis In another thread you stated that Shortpixel does not server WebP to browsers that can not handle it. Problem is, with shortpixel activated, no images are showin on Safari if WebP is activated. Disable the display of WebP and its displayed. So, in other terms: Shortpixel is trying to show webP to all browsers?

    Plugin Support Gerard Blanco

    (@sixaxis)

    Hi Romeon,

    ShortPixel doesn’t show WebP to all browsers, so there’s probably an issue with your website. Can you please contact us here, mention this conversation, and send us the following information?

    • Your website
    • A screenshot of your ShortPixel settings

    Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.