Support » Plugin: WebP Converter for Media » WebP images are not transferred

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hi @deralict,

    Thank you for your message. I will try to help you. Follow these steps:

    1. Read the entire FAQ for this plugin, in particular the question “How to check if plugin works?”.

    2. Do you use CDN? If so, please see the question “Does the plugin support CDN?” in plugin FAQ.

    3. Do you use other plugins to optimize images? Please disable them and check this plugin without them. Remember not to combine several optimization plugins because they can be mutually exclusive.

    4. Check if in /wp-content/uploads-webpc/ directory are all files that should be converted.

    If not, please enable WP_DEBUG_LOG in your wp-config.php (more about debugging: https://codex.wordpress.org/WP_DEBUG). That’s what you should have in this file:

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    Next click Regenerate All on settings page of plugin. Do you have any errors in /wp-content/debug.log?

    5. Please check all other threads in this support forum. It is very common for problems to recur. Perhaps someone had a similar problem and it has been resolved. If so, let me know which thread has helped you.

    If you solved your problem then, mark your issue solved. If not, please send me following information:

    6. URL of your website. If your site is not publicly available, add it to test environment.

    7. Configuration of your server (link to it can be found on the settings page of plugin in the “We are waiting for your message” section) – please take a screenshot of the ENTIRE page and send it to me.

    Directly URL: /wp-admin/options-general.php?page=webpc_admin_page&action=server

    8. Content of your .htaccess file.

    9. Check in configuration of your server if you have enabled modules mod_mime, mod_rewrite and mod_expires. Please contact your hosting provider in this case.

    When sending your answer, keep the numbers from 1 to 9. Please answer exactly every question.

    deralict

    (@deralict)

    Thanks for the reply.

    1. I did read the FAQ…this is how I was able to determine that it was not working (according to the FAQ).

    2. I’m not using a CDN.

    3. I’m not using any other image optimization plugins.

    4. Yes, all the webp files are in the /wp-content/uploads-webpc/ directory.

    5. I went through all support threads before I started my own…that’s why I knew to include the screenshots I provided. I also verified the server has the required modules enabled.

    6. The URL is http://fishinglodgesandresorts.com/lodge/aylmer-lake-lodge. It is not publicly available (still being developed) but I’m not sure what you mean by “add it to test environment”.

    7. Here is a screenshot of the entire server config page: https://www.dropbox.com/s/oey17zo6ns20ket/entire-page.pdf?dl=0

    8. .htaccess file content: https://www.dropbox.com/s/r7pk1jvb9upm6ik/htaccess.png?dl=0

    9. Yes I confirmed with the hosting company those modules are enabled.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    In that case, it looks like your htaccess rules don’t work because of the server configuration or mod_rewrite module not working.

    deralict

    (@deralict)

    I confirmed with the hosting provider that mod_rewrite is on and working properly. To verify I added a simple 302 redirect, and tested that it works (it does): https://www.dropbox.com/s/tifgu7s0lz1l2u7/new-htaccess.png?dl=0

    Any other ideas?

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Please try add a specific image redirect (RewriteRule itself using [T=image/webp]). Add the exact path without regex and skip RewriteCond.

    deralict

    (@deralict)

    OK I created this rule (not sure if my syntax is correct) to taget a single image:
    RewriteRule /wp-content/uploads/acc5-400×267.jpg http://fishinglodgesandresorts.com/wp-content/uploads-webpc/acc5-400×267.jpg.webp [T=image/webp]

    Here is hwo htaccess looks now: https://www.dropbox.com/s/kutda7zfbxfmbt5/Screenshot%202019-10-14%2014.08.44.png?dl=0

    Still doesn’t work…

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Here you have correct line:
    RewriteRule (.+)/uploads/acc5-400x267.jpg $1/uploads-webpc/acc5-400x267.jpg.webp [T=image/webp]

    deralict

    (@deralict)

    OK I changed that line, here is how htaccess looks now: https://www.dropbox.com/s/ukzt2y5pfc0j5in/Screenshot%202019-10-14%2014.25.11.png?dl=0

    Still no work…

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Sorry, but in that case, I can’t help you any more. This is a problem with the server. Do you have the option to contact support and try to solve this problem?

    You will let me know if it succeeds. I’d love to know the solution!

    deralict

    (@deralict)

    OK, I have figured it out. There was a server misconfiguration issue—the hosting company said that images were served by Nginx so they had to reconfigure it to bypass Nginx…or something like that. Not sure entirely. But I have confirmed that it does work.

    HOWEVER, I noticed that the webp image that was now used instead of the source jpg image, was larger than the jpg image! I looked at all the webp images in the /uploads-webpc directory that had been converted, and noticed that while some of the smaller ones had been reduced is size when converted to webp, most of the files were larger in webp format.

    I then did a test on one of the images that was larger in it’s webp format with an online converter. I compared the output of it to the webp version that your plugin created and to the original jpg file. It was 7% smaller than the original jpg, and 38% smaller than the webp created by your plugin.

    Original image: http://fishinglodgesandresorts.com/wp-content/uploads/acc3-1.jpg

    JPG: 225kB
    Webp (your plugin): 327kB
    Webp (online converter): 203.8kB

    So even after getting the plugin to technically work, the conversion to webp does not actually make the site load faster (the opposite actually).

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    It’s very strange. The WebP format allows you to limit the size of images to a very large extent.

    What is your quality level set?

    Your photo has very low quality. This means it already has a lot of compression. Check it in a good quality photo.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @deralict, I have released an update that automatically deletes files if they are larger than the original.

    Please download version 1.0.6 and tell me, does everything work as you would like? Use the Regenerate All option to convert all images.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.