Support » Plugin: ShortPixel Image Optimizer » WebP files saved with double extension

  • Hi there
    I’ve been noticing this behaviour for some time now: jpg files (be it with .jpg or jpeg extension) are saved as WebP files with a double extension: <name>.jpg becomes <name>.jpg.webp, <name>.jpeg becomes <name>.jpeg.webp.
    I don’t think this is the behaviour you want, it certainly wasn’t this way before.

    Thanks
    P

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author ShortPixel

    (@shortpixel)

    Hey @pollensteyn – thanks for your message and for using ShortPixel! đŸ™‚

    Please read here about the reasons why we started having 2 versions of the same WebP file since version 4.12.8.

    Best regards,
    Alex

    Thanks for your reply, I now see the logic of this behaviour. But… the reason I noticed it is because of the CacheEnabler plugin still referencing to the jpg versions in the webp cache files and not the webp counterparts, so name.jpg instead of name.webp. The creation of symlinks would be a workaround only if they are actually being created on my server, but they aren’t. So name.webp isn’t served, only name.jpg.webp.
    My workaround is renaming the *.jpg.webp files

    Thanks
    P

    [ Please do not bump. ]

    • This reply was modified 1 year, 4 months ago by pollensteyn.
    • This reply was modified 1 year, 4 months ago by pollensteyn.
    • This reply was modified 1 year, 4 months ago by pollensteyn.
    • This reply was modified 1 year, 4 months ago by pollensteyn.
    Plugin Author ShortPixel

    (@shortpixel)

    Thanks for additional details, we’re looking into the symlink problem.
    Would having both images created be a solution for you?
    Also, would it be useful to have an option for creating one or both version of images? No symlinks I mean, actually duplicate the images on disk.

    Thanks,
    Alex

    Thanks for the reply, and sorry for the bump, my bad…
    I don’t think saving the image twice is the best solution. Aside from added disk space consumption, it only adds more to the confusion. Generally I don’t like files with a double extension when there is no real need for it, but I can see the logic here. Maybe saving the name.jpg as name.webp, unless there is a name.png already present and then saving name.jpg as name.jpg.webp (or name.png as name.png.webp and name.jpg as name.webp)? But this implies kind of a reversal in behaviour which will cause other problems, I guess. Regarding the symlinks, I would prefer server side directives. For me personally, I don’t mind renaming the files, it’s a trivial process.
    Thanks
    P

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WebP files saved with double extension’ is closed to new replies.