Support » Plugin: LiteSpeed Cache » WebP browser caching

  • Resolved ronnieee

    (@ronnieee)


    I am using the Image WebP Replacement option in LiteSpeed Cache.
    I’ve also set Browser Cache to On, with Browser Cache TTL of 2592000, and the htaccess file includes ExpiresByType image/webp A2592000, so I would expect the browser to cache the generated .jpg.webp and .png.webp files, yet GTmetrix tells me “expiration not specified” for these files.

    When I use a straight .webp file on a page there is no problem, so it seems image/webp does not work for the files generated by the Image WebP Replacement. Any suggestions?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Could you please provide the report number ?

    You can get it from Toolbox –> Report, and click “send to LiteSpeed”

    Best regards,

    Thread Starter ronnieee

    (@ronnieee)

    The report number is HZEUCUES
    Thanks!

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    [root@test ~]# curl -I -XGET https://xxxxxxxx/wp-content/uploads/2020/07/Rigid-Audio-Viego-deal-324x235.png.webp
    HTTP/1.1 200 OK
    Connection: Keep-Alive
    Cache-Control: public, max-age=2592000
    Expires: Wed, 12 Aug 2020 00:55:34 GMT
    Content-Type: image/webp
    Last-Modified: Fri, 10 Jul 2020 13:55:04 GMT
    Accept-Ranges: bytes
    Content-Length: 11294
    Date: Mon, 13 Jul 2020 00:55:34 GMT
    Server: LiteSpeed
    Alt-Svc: quic=":443"; ma=2592000; v="43,46", h3-Q043=":443"; ma=2592000, h3-Q046=":443"; ma=2592000, h3-Q050=":443"; ma=2592000, h3-25=":443"; ma=2592000, h3-27=":443"; ma=2592000
    
    [root@test ~]# curl -I -XGET https://cdn.xxxxxxx/wp-content/uploads/2020/07/Rigid-Audio-Viego-deal-324x235.png.webp
    HTTP/1.1 200 OK
    Date: Mon, 13 Jul 2020 00:55:40 GMT
    Content-Type: image/webp
    Content-Length: 11294
    Connection: keep-alive
    Last-Modified: Fri, 10 Jul 2020 13:55:04 GMT
    Alt-Svc: quic=":443"; ma=2592000; v="43,46", h3-Q043=":443"; ma=2592000, h3-Q046=":443"; ma=2592000, h3-Q050=":443"; ma=2592000, h3-25=":443"; ma=2592000, h3-27=":443"; ma=2592000
    Server: CDN77-Turbo
    X-Edge-IP: 195.181.172.1
    X-Edge-Location: amsterdamNL
    X-Cache: HIT
    X-Age: 208595
    Accept-Ranges: bytes

    your CDN removed those headers.

    Best regards,

    Thread Starter ronnieee

    (@ronnieee)

    Excellent, thanks!

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    You should be able to change this behavior in your CDN dashboard , if not , you may need to contact CDN support for this matter.

    Best regards,

    Thread Starter ronnieee

    (@ronnieee)

    The problem was actually that the CDN had files cached without the expires headers from before I had set the browser cache settings in LiteSpeed Cache, so a quick purge of the cached files and all is well. Thanks again for helping me figure it out!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WebP browser caching’ is closed to new replies.