• Resolved andrewescott

    (@andrewescott)


    Thanks for writing the ActivityPub plugin. I’ve struggled to get it to work, with my two fundamental issues being (i) my nickname is different to my admin name on my single-user WordPress blog, and (ii) WordPress is unable to rewrite the path to webfinger for some reason.

    I tackled the first one by turning off “Enable authors” and turning on “Enable blog” in the the ActivityPub plugin settings, and using the nickname in the blog profile ID.

    I tackled the second one by manually creating a webfinger file following the approach at https://github.com/Automattic/wordpress-activitypub/issues/188 but I had to also replace the href/alias references to the author page of my blog.

    Once I’d done both of these, Mastodon was able to follow the posts on the blog. It would be great if I didn’t have to do these workarounds though.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Matthias Pfefferle

    (@pfefferle)

    Can you maybe post your blog-url here, so I can have a look.

    May I ask where you host your blog?

    Thread Starter andrewescott

    (@andrewescott)

    Thanks. My blog is hosted on a cPanel-based provider (Ventra IP) which uses Apache, and you can find it at https://aes.id.au (where @andrew@aes.id.au should be the “Mastodon profile” that the blog feed is exposed through).

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Would you consider switching to “pretty permalinks” under Settings > Permalinks? Any permalink other than the plain permalinks would be helpful.

    If you can make that change, let us know if that fixes the issue!

    Thread Starter andrewescott

    (@andrewescott)

    Thanks. It was a bit of a pain to ensure that my old permalinks would continue to work inbound, but the Redirects plugin helped. Now that I’m no longer using plain permalinks, webfinger works! (I’ve since deleted the .well-known/webfinger file.) However, I can’t follow @andrew@aes.id.au from Mastodon, i.e. the ActivityPub settings Followers page doesn’t show any followers, and no new posts show up when I follow it from elsewhere (even though it looks like it worked from the client side).

    Thread Starter andrewescott

    (@andrewescott)

    I take it back. I had to unfollow the WordPress blog, and then (using a different Mastodon app, since the old Webfinger document had been cached), follow the blog again. Once I did this, a new follower showed up in the ActivityPub settings Followers page.

    The big blocker seems to be that plain permalinks stopped the plugin working originally.

    Thread Starter andrewescott

    (@andrewescott)

    Thanks for the help!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.