WordPress.org

Forums

web.config redirect problem (1 post)

  1. ProCessor
    Member
    Posted 2 years ago #

    Hi there,

    I am having trouble configuring the web.config file (host uses windows IIS servers).
    With permalink setting to /%postname%/ a 404 error occured (when visiting homepage), the rest of the pages worked perfectly (with .../slugname).

    In order to fix the issue with the homepage, the host had configured this web.config file:

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.webServer>
          <rewrite>
            <rules>
              <rule name="Main Rule" stopProcessing="true">
                <match url=".*" />
                <conditions logicalGrouping="MatchAll">
                  <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
                  <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
                </conditions>
                <action type="Rewrite" url="index.php/{R:0}" />
              </rule>
            </rules>
          </rewrite>
           <httpRedirect enabled="true" destination="/home" childOnly="true" />
          </system.webServer>
    </configuration>

    Now it works, but yet another problem occurs.
    The WordPress Dashboard isn't reachable anymore by /wp-admin or /wp-login.php

    Both are changed to /home/wp-admin or /home/wp-login.

    Any idea on how to fix this?
    Is there an option to exclude *.php files or something from redirecting?

    Hope you can help out!

Topic Closed

This topic has been closed to new replies.

About this Topic