WordPress.org

Support

Support » How-To and Troubleshooting » Web.config file causing 500 – Internet Server Error

Web.config file causing 500 – Internet Server Error

  • I’m not sure why this all of a sudden happened but it’s happening on new installations of WordPress. We recently upgraded our version of Plesk but all the installations of WordPress that are already up and running remain working and everything new that I’m trying to install is receiving this problem.

    I already have a lot of custom features that I’ve worked on in my WordPress installation so instead of installing a brand new installation I just download the files from my original WordPress installation and upload it onto the new server. Go into the database, change the URL path, change the security key, and the MySQL credentials. This has been working but now what’s happening is when the web.config file is present I get a 500 – Internal Server Error. When I delete the web.config I can access the website just fine, but I’ve had the same permalink structure since the original and I’d like to keep it.

    I have .htaccess, secure.htaccess, and default.htaccess files and have tried keeping those and deleting those as well and it makes no difference so I’ve narrowed it down to specifically web.config. I’ve tried setting permissions on it through the Plesk control panel, I’ve tried deleting the content in web.config and leaving it blank (that still gives 500 error).

    We’re unable to switch to Linux because we have GoDaddy dedicated Windows servers and we don’t know how to manage Linux servers as well as as we do Windows.

    The only change is the Plesk upgrade, anyone know what could have happened all of a sudden and how it can be fixed? Thanks for your time!

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Web.config file causing 500 – Internet Server Error’ is closed to new replies.