Support » Plugin: Webcomic » Webcomic not posting, media not appearing

  • Hi there. I’ve started building a site on Bluehost but have run across two problems with the plugin:

    – The webcomic is not posting to the home page, which is set to show latest posts. Instead the home page displays a “nothing found” error.
    – When I visit the permalink for an individual comic page, everything appears except the webcomic media.

    I have tried the plugin with a couple of different themes with no luck. Any ideas? Thank you!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Mike


    Hey @livcordray, apologies for the trouble. Have you selected an integration option in the Webcomic section of the customizer? For most themes, Webcomic won’t actually display anything unless you either modify the theme a bit or turn Integration on (the Universal option is designed to work with most themes). You can read more about integration here.

    Hi @mgsisk, yes, I’ve tried all the different integration options with various themes.

    Plugin Author Mike


    The problem might be partially with how integration works; I tried MK (your current theme, from the looks of it) and it does work with the Universal integration option. If you turn on Universal integration, you should at least get comic media and navigation on individual comic pages.

    The homepage is a little trickier… Webcomic needs something to integrate with, and on a lot of pages that something is the WordPress loop. On the homepage, that means you generally need at least one regular, published post, or the loop never runs and Webcomic has nothing to integrate with. What you might try is publishing one regular post (with or without content, doesn’t matter, as long as it’s published), and then just hide it on the homepage by adding some additional CSS to the customizer, like:

    .home { display: none; }
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Webcomic not posting, media not appearing’ is closed to new replies.