Webcomic just died! (9 posts)

  1. tthorpe1206
    Posted 3 years ago #

    I updated to the new webcomic version and now it doesn't show up in my wordpress sidebar, I can't access any settings regarding webcomic, I can't access any of my pages and none of my pages show up on my site. what the hell happened??


  2. EspenT
    Posted 3 years ago #

    Same happened here. I managed to get it to show up in my sidebar by deactivating and then activating the plugin. But I still can't run the upgrade tool. All I get when pressing the upgrade button is a blank, white screen.

  3. tthorpe1206
    Posted 3 years ago #

    okay, now I've run the upgrade and exported all my content, but when I try to import it I'm told it's all in the wrong format!

  4. tthorpe1206
    Posted 3 years ago #

    Also, none of my newly created pages are showing up, either. What the hell did you do?????
    This has COMPLETELY messed up my comic! NOTHING IS WORKING!!

  5. ad1066
    Posted 3 years ago #

    I'm having a similar problem. I help maintain the site for the Bill the Cockroach webcomic (www.billthecockroach.com), and after updating to 4.0, all we're getting is an error that says Call to undefined function previous_webcomic_link(), and there's no option in the admin menu for it.

  6. EspenT
    Posted 3 years ago #

    I've managed to roll back to version 3, but now only the latest page shows, even though I can view them all in the admin panel.

  7. majic13
    Posted 3 years ago #

    Updated to the new version, and the upgrade/conversion tool is broken - whenever I try to run it I just get a 500 server error. Rolling back to version 3 is just as much of a headache, as it variously seems to have either lost all the image file info, or fails to recognise the default Collection.

    Really looking forward to this getting fixed.

  8. tthorpe1206
    Posted 3 years ago #

    I managed to roll back to webcomic 3 and, while I have access to all of my pages now, when I try to add a new page it won't upload my image file into the ccomic navigation.

  9. Mike
    Plugin Author

    Posted 3 years ago #

    Apologies for the trouble everyone. I'm aware that some users are having issues upgrading from Webcomic 3, but I haven't determined what exactly is causing the issue just yet. A few things that might help:


    If you're upgrade fails but you still have access to the Upgrade Webcomic page, the safest way to downgrade is to click Not Interested button on that page to uninstall Webcomic 4 and then reinstall Webcomic 3 (which can be downloaded from here or here). This should retain your Webcomic 3 settings properly.

    Webcomic 3 Settings MIssing

    Missing settings are the cause of most issues if you've attempted to upgrade and then downgraded back to Webcomic 3 (including the inability to properly set a default collection). The process described above should maintain these settings (it's also shouldn't fail, of course, and we know how that's going).

    If it doesn't retain your Webcomic 3 settings or your settings were lost for some other reason the easiest way to restore them is from a backup. You shouldn't need to do a full-site restore; only Webcomic 3's settings should be missing (even when it fails, Webcomic 4's upgrade process shouldn't delete any of your data except for these "old" settings). Webcomic's settings can be found in the wp_options table of the WordPress database with an option_name of webcomic_options.

    If you your settings didn't transfer correctly and you don't have a backup you can try checking that same database table for an option named webcomic_legacy. This is a temporary option Webcomic 4 uses to store your old settings for use during the upgrade. If it exists (and isn't empty) you should be able to copy and past the value from this option into the correct webcomic_options setting.

    If all else fails, simply updating your settings from the Webcomic > Settings administrative page will rebuild the settings, but certain features may or may not work.

    404 Error's after a Downgrade

    If everything looks correct but you're getting 404 errors on webcomic-related pages your pretty permalink settings may need to be flushed. This can be done by changing the Permalink setting and saving (then switching back and saving again) or by adding the following function to your theme functions.php file:

    flush_rewrite_rules( true );

    and visiting any page on your site. If you try using flush_rewrite_rules() you should remove it after you've visited a page or two; it's not meant to be run on every single page load (which is what happens when you add it to your theme functions.php file).

    Apologies again for the trouble. I'm currently at a day-job-releated conference, and almost never drop in at WordPress.org besides. I've set it so that I'll be notified of future posts to this thread, but I'd recommend posting on the Webcomic Google Group for further assistance (many of these issues have been discussed there already).

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Webcomic
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic