Support » Plugin: Web Stories » web stories analytics not displaying

  • Resolved Yen511

    (@apeachyplate)


    I’ve created some web stories, submitted a site map and it’s been AMP verified. Google site kit has automatically input the analytics ID under settings. It’s been over a week and I still cannot view the analytics under Behavior –>top events. There has been an increase of traffic, but it’s coming from “direct”. I believe that’s from the web stories, but I can’t locate the source.

    I would also like to use a separate analytics ID to track the web stories, but there’s no way to add a new analtyics ID in settings as it’s grayed out.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • @apeachyplate thanks for reaching out!

    Could you share the URL of a published story on your site?

    On my test site, I use Site Kit for Analytics and I can see Stories are being tracked in my Analytics account under Behavior > Events. The title of the story is indicated in the “Event Category” column (screenshot).

    I would also like to use a separate analytics ID to track the web stories, but there’s no way to add a new analtyics ID in settings as it’s grayed out.

    I’ll check with the team about what’s possible here. In the meantime, it would be good to confirm if the current configuration with Site Kit is working properly.

    Thread Starter Yen511

    (@apeachyplate)

    This is the URL to one of the stories.
    https://apeachyplate.com/web-stories/suon-ram-man/

    All the stories are just nested on this page https://apeachyplate.com/web-stories/

    @apeachyplate actually I see you have a story available here.

    When I check the source code, I don’t see the <amp-analytics> code snippet on the site.

    Could you clear the cache of your caching plugin and let me know so I can check once more?

    Thread Starter Yen511

    (@apeachyplate)

    cache is cleared.

    @apeachyplate thank you!

    So I still don’t spot the amp-analytics snippet, but interestingly I also don’t spot an Analytics snippet on the other pages of the site.

    Do you currently have Site Kit connected to Analytics and have the toggle to let it place the code turned on in the settings?

    Thread Starter Yen511

    (@apeachyplate)

    The analytics code is grayed out. It won’t allow me to input a code, it’s already been inputted by site kit. Here’s the what it states:

    Site Kit by Google has already enabled Google Analytics for your Web Stories, all changes to your analytics tracking should occur there.

    @apeachyplate thanks for your reply. This message in the Web Stories settings indicates that Site Kit is installed and active.

    Could you navigate to Site Kit > Settings > Analytics > Edit to confirm the code snippet is being inserted as in this screenshot?

    Thread Starter Yen511

    (@apeachyplate)

    I just switched it to add the code:

    “Analytics Code Snippet
    Snippet is inserted”

    Web stories analytics has not appeared under top events yet.

    @apeachyplate thanks for the update! I can now see the amp-analytics snippet in the source code of your story as well as the snippet on the other pages of your website.

    Since it seems the tracking code has just been inserted, it may take some time for the data to appear in your Analytics account. Let’s follow up in a few days to ensure you see data there.

    @apeachyplate I’m just following up to see if data appeared for your stories in your Analytics account?

    Also note we have this open feature request to support providing a different tracking ID for stories. Feel free to subscribe to the Github issue for progress updates.

    Thread Starter Yen511

    (@apeachyplate)

    thank you. analytics are displaying for every web story.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘web stories analytics not displaying’ is closed to new replies.